» Poradna » Programy

Vzorec v excelu

 |   |  Microsoft Windows Vista Firefox 11.0

Dobrý den. Prosím o radu s excelem. Už jsem postarší uživatelka PC, před několika lety jsem absolvovala takový rychlokurz na program MS office. No roky šly, ke své práci jsem potřebovala Word a občas něco "sesmolit" v excelu. To víte že jsem za roky kdy jsem to neměla zapotřebí pozapomínala kde co. Teď po mě ovšem v práci požadují něco, s čím si nevím rady a i když hledám na internetu, tak z nalezených rad nejsem moudrá a nechápu to jak to mám uplatnit na můj problém. Jedná se o to, že máme tabulku s přibližně 40 jmény a u nich je čerpání náhradního volna. A já mám vytvořit vzorec, který mi automaticky dosadí za cca 20 - 21 pracovních dnů překročení prac. volnaTabulku mám, ale nevím si rady jak zadat vzorec, v mém konkrétním případě uvedu:řádek 5, Novák, sloupec 2 až 21, ve sloupcích uvedeno číslovkami (tak to chce šéf) 1 = byl v práci v kanceláři, 2 = byl v práci ale na služební cestě, 3 = byl v práci u zákazníků, 5 = náhradní volno, 8 = nemoc, 9 = jiné.Já potřebuji, aby mi to - pokud je v měsíci nějaká položka 5 napsalo do posledního sloupce v řádku (u mě 23 sloupec) čerpal NV, respektive pokud není položka 5 - nečerpal NV.Prosím můžete mi s tím někdo znalý pomoci. Já to opravdu podle těch návodů nechápu (a to nejsem blond....)

Odpovědi na otázku

 |   |  Microsoft Windows XP IE 8.0

Možné riešenieV riadku 5 a vo Vašom stĺpci 23 ( Z ? ) zapíšteak Vaše písmeno stĺpca 2 je B a stĺpca 21 je V=KDYŽ(COUNTIF(B5:V5;5)>0;"čerpalNV;"nečerpalNV)v ďalšom stĺpci ( napr.:24) si prípadne zapíšte =COUNTIF(B5:V5;5) = početNV

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP IE 8.0

Doplnenievo vzorci má byť pochopiteľne "nečerpalNV"v ďalších stĺpcoch si môžete zapísať napr.: =COUNTIF(B5:V5;1), =COUNTIF(B5:V5;2) ......

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows Vista Firefox 11.0

Možná jsem to popsala špatně.... Zde na odkazu jsem narychlo sestavila podobmou tabulku a jaký tedy vzorec zkopírovat do N ????http://ulozto.cz/xcoE9k6z/nevybral-nv-xlsx

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Opera 9.80

=KDYŽ(COUNTIF(B2:L2;5)>0;"čerpalNV;"nečerpalNV)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Opera 9.80

ach ty uvozovky=KDYŽ(COUNTIF(B2:L2;5)>0;"čerpalNV";"nečerpalNV")

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Chrome 31.0.1650.63

=KDYŽ(COUNTIF(B2:L2;5)>0;"čerpalNV";"nečerpalNV")

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Podľa zadaného príkladu chcete v stĺpci N slovne vypísať VybralNV alebo NevybralNVZápis pre A2 Adámek N2 = KDYŽ(COUNTIF(B2:L2)>0;"VybralN";"NevybralNV")v tomto prípade viete len či vybral alebo nevybral, ale neviete počet NVAdámek nevybralNV, Jindrák vybralNVAk chcete vedieť aj počet dní NV zapíšte do stĺpca OO2 = COUNTIF(B2:L2;5) Adámek 0; JIndrák 1Podobne si môžete v ďalších stĺpcoch zistiť počet dní v kancelárii, u zákazníka, atď.....Ak ďalšie otázky - odpíšte

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows Vista Firefox 11.0

Děkuji za snahu. 1.Nepotřebuji vědět počet těch dnů, jen jestli ano či né, pro rychlou orientaci pro nadřízeného.2.Abych řekla pravdu, tak přes horní lištu najedu do nabídky vzorce, kliknu na vložit funkci, nakopíruju Vámi vytvořené do tabulky "podmínky funkce - = KDYŽ(COUNTIF(B2:L2)>0;"VybralN";"NevybralNV") a napíše mi to v tabulce za tou podmínkou červeně Neplatné a jsem v koncích... Prostě nevím kudy kam

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Nemusíte klikať na funkcie, aleKliknite na buňku N2 a priamo v buňke nápíšte =KDYŽ(COUNTIF(B2:L2;5)>0;"VybralNV";"NevybralNV")Len žiadne "jsem v koncích"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows Vista Firefox 11.0

Super. Mnohokrát děkuji. Pomalu jsem měla strach jít zítra do práce a sdělit nadřízenému že to nemám a neumím to. Ono to je dnes tak, že pokud neumím něco co mi zadají, aby měl člověk v mém věku pomalu strach o práci.... Ještě jednou děkuji, práci se nemám koho zeptat - bohužel a ono "někdo" třeba nechápe, že učený z nebe nespadl a chyby se hledají všude kolem u všech - jen né u sebe. Hezký zbytek večera

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

OK! a ak si ešte do buňky O2 zapíšete = COUNTIF(B2:L2;5) a do buňky O10= SUMA(O2:O9) = počet všetkých vybranýchNV, šéf to iste ocení a môžete ísť kľudne do práce.Držím palec !

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Vzorec, Program MS, Čerpání, Uživatelka, Překročení, Nemoc


Určitě si přečtěte

Nejlepší programy z roku 2000: Další várka zapomenutých legend, které jste měli v PC

Nejlepší programy z roku 2000: Další várka zapomenutých legend, které jste měli v PC

** Pokračujeme ve vzpomínání na prehistorické programy ** Pročetli jsme vaše tipy v diskuzi ** A všechny ty vykopávky spustili na Windows 2000

Jakub Čížek | 74

Co přijde po Netflixu a Amazonu? Tohle jsou streamovací služby, na které v Česku čekáme

Co přijde po Netflixu a Amazonu? Tohle jsou streamovací služby, na které v Česku čekáme

** Rozhodujete se mezi Netflixem a HBO Go? Věřte, bude hůř ** Na trhu je mnohem víc ambicióznějších streamovacích služeb ** Některé by mohly do ČR zamířit ještě letos

Lukáš Václavík | 45

Na měsíc jsem opustil Google a potupně se zase vrátil zpět (komentář)

Na měsíc jsem opustil Google a potupně se zase vrátil zpět (komentář)

** Zkusil jsem se zbavit závislosti na vyhledávači od Googlu ** Jako alternativy posloužily Bing, Seznam a DuckDuckGo ** Mají své silné stránky, ale i nepřekonatelná negativa

Lukáš Václavík | 61

Deset kotev, které i v roce 2020 táhnou Android ke dnu

Deset kotev, které i v roce 2020 táhnou Android ke dnu

** Android existuje skoro 12 let a za tu dobu v mnoha směrech dospěl ** Dnes běží na sedmi z deseti telefonů, ale čemu za to vděčí? ** Našli jsme 10 kotev, které táhnou tento operační systém ke dnu

Karel Kilián | 169

Jak odposlouchávat sousedy: Bizarní Lamphone a další netušené techniky

Jak odposlouchávat sousedy: Bizarní Lamphone a další netušené techniky

** Lamphone je další bizarní technika odposlechu ** Zneužívá obyčejnou stropní lampu ** Podívejte se na další bizarní experimenty

Jakub Čížek | 17

Windy je laboratoř na počasí: 12 tipů, jak se ve službě vyznat a využít ji naplno

Windy je laboratoř na počasí: 12 tipů, jak se ve službě vyznat a využít ji naplno

** Předpověď počasí Windy nabízí nepřebernou škálu funkcí ** Zorientovat se v nich nemusí být vždy snadné ** Proto přinášíme 12 užitečných tipů a triků

Karel Kilián | 10


Aktuální číslo časopisu Computer

Megatest: nejlepší notebooky do 20 000 Kč

Test 8 levných IP kamer

Jak vybrat bezdrátová sluchátka

Testujeme Android 11