» Poradna » Programy

Vzorec excelu

 | Microsoft Windows 7 Chrome 76.0.3809.132

Dobrý den,potřebuji poradit se vzorcem do excelu, který by měl na základě rozměrů boxu vydělit jinou buňku buď 20 nebo jiným číslem (přepočet na paletovou jednotku).Příklad:=KDYŽ(A=600;B=400;C=320 **tady nevím jak to udělat.. Když splňuje tyto tři podmíny vyděl D 20)Potřebuji aby vzorek rozeznal rozměry boxu a udělal z toho paletu. Boxy 600x400x320 jde na paletu po 20ks a např. box 600x400x420 jde na paletu po 15ks.Má někdo nápad?

Mohlo by vás také zajímat

Odpovědi na otázku

 |   |  Microsoft Windows 10 Firefox 69.0

Ty 3 podmínky musíš spojit do jedné pomocí A(podmínka1;podmínka2;...).=KDYŽ(A(A1=600;B1=400;C1=320);výpočet1;výpočet2)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Android Chrome 76.0

Takže kdybych chtěl více podmínek vzorec by měl vypada takto?=KDYŽ (A(A1=600;B1=400;C1=320);D1/20);(B(A1=600;B1=400;C1=420);D1/15);(C(A1=800;B1=600;C1=320);D1/8)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 69.0

Ne, v "když" máš jen 3 parametry:=KDYŽ(podmínka;výsledek1;výsledek2)podmínka se vyhodnocuje a musí být ANO/NEvýsledek1 se použije, pokud vyjde ANOvýsledek2 se použije, pokud vyjde NETakže pokud chceš více podmínek, musíš tam narvat další "když".=KDYŽ(A(A1=600;B1=400;C1=320);D1/20;KDYŽ(A(A1=600;B1=400;C1=420);D1/15;KDYŽ(A(A1=800;B1=420;C1=320);D1/8;*****)))místo ***** pak něco, co se provede, pokud není splněno ani jedno, třeba D1/10.Zda jsem tam něco nenapsal blbě ti ale nepovím, nezkoušel jsem to v excelu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 69.0

Pokud těch typů palet máš ale hodně, tak je tohle cesta do pekel.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Android Chrome 76.0

Nene palety jsou jen dva typy, ale boxu je asi 6-7typu. Vyzkouším v Excelu a dám info jestli se povedlo

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 69.0

Tak na 6-7 už to bude vzorec jako kráva ve kterém se snadno ztratíš a chybu nenajdeš.Nedá se to určit nějak jinak? Například podle objemu? Pokud má každá jiný, bylo by to o dost jednodušší a nepotřeboval bys vůbec žádné "když". Třeba takto:=D1/(SVYHLEDAT(A1*B1*C1;List2!$A$1:$B$99;2;NEPRAVDA))S tím že na straně "List2" máš ve sloupci A seznam objemů a ve sloupci B pak hledaného dělitele, kterých může být, kolik je třeba. Jen se musí lišit objemy. Např.:76800000 20100800000 15107520000 10141120000 5

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.100

Musíš použít booleovu algebru. Správně operátory AND, případně OR, pokud by stačilo, aby byla splněna jen jedna podmínka. V českém Excelu jsou ale takové blbé překlady, takže A a NEBO.KDYŽ(A(A1=600;A2=400;C2=320)...A1, A2, A3 jsou buňky

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Chrome 76.0.3809.132

Pokud vidím dobře, tak se ty palety liší pouze jedním parametrem takže stačí kontrolovat jeden. Ostatní jsou identické. Takže stačí vzorec udělat následovně KDYŽ(C1=420;15;20). Vzorec kontroluje, zda je výška, nebo co je to za rozměr (C1) 420, pokud ano, vloží 15, jinak vloží 20.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 69.0

Pro tyhle dva typy stačí, když předpokládaný objem palety (cca 1,5m3) vydělíš objemem krabice a zaokrouhlíš. A nebo vytvoř list/tabulku typů krabic, zadáš typ a pro rozměry a počet kolik se jich na paletu vejde si sáhneš pomocí SVYHLEDAT nebo jiné excel fce.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Android Chrome 76.0

Jde o logistický koncept, který by měl vypočítat limit skladových zásob. Mám tabulku, která mi převádí určitý počet výrobků dle ulounosti na boxy. Boxy mají rozměry 60x40x32,42 nebo 80x60x28,32. Různé výšky znamenají různou uloznost na paletu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 69.0

Pak by to měl řešit SW skladové evidence ze svých dat a ne uživatel v excelu

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Android Chrome 76.0

Bohužel logistika lightingu je hodně pozadu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 7 Chrome 76.0.3809.132

Tak jsem to nakonec vyřešil takto a funguje to. Dík za rady.=KDYŽ(N4+O4+P4=3175;I4/1;KDYŽ(N4+O4+P4=1320;I4/20;KDYŽ(N4+O4+P4=1420;I4/15;KDYŽ(N4+O4+P4=1280;I4/20;KDYŽ(N4+O4+P4=1220;I4/25;KDYŽ(N4+O4+P4=1180;I4/35;KDYŽ(N4+O4+P4=1720;I4/8;KDYŽ(N4+O4+P4=1680;I4/8;KDYŽ(N4+O4+P4=1620;I4/10;KDYŽ(N4+O4+P4=1580;I4/14;KDYŽ(N4+O4+P4=2960;I4/1;"Chybné rozměry")))))))))))

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Přepočet, Vzorek


Určitě si přečtěte

Google není jen vyhledávač: 15 užitečných funkcí, o kterých možná ani nevíte

Google není jen vyhledávač: 15 užitečných funkcí, o kterých možná ani nevíte

** Google umí kromě vyhledávání i spoustu dalších věcí ** Vybrali jsme více než 15 užitečných funkcí a schopností ** Stačí zadat do vyhledávače ta správná klíčová slova

Karel Kilián | 22

Karel Kilián
TipyVyhledávačeGoogle
Dostali jste nový počítač? Tohle s ním udělejte, než ho začnete používat

Dostali jste nový počítač? Tohle s ním udělejte, než ho začnete používat

** Každý nový počítač si zaslouží počáteční péči ** Odinstalujte bloatware a nezapomeňte na vhodné nastavení ** Poradíme, jak se o počítač s Windows 10 postarat

David Polesný, Stanislav Janů | 75

David PolesnýStanislav Janů
PočítačeNotebooky
Pozor na tyto doplňky pro Chrome a Edge. Mohou obsahovat malware, varuje Avast
Jakub Čížek
MalwareProhlížeče
Jak se šíří Covid v Česku: Čerstvá data, semafor PES, mapy okresů a obcí. Každý den aktualizované grafy

Jak se šíří Covid v Česku: Čerstvá data, semafor PES, mapy okresů a obcí. Každý den aktualizované grafy

** Vývoj COVID-19 v Česku: nakažení, úmrtí, testovaní, hospitalizovaní ** Mapa podle okresů, přehled podle věku, situace v Evropě i ve světě ** Každý den aktualizované grafy a mapy

Marek Lutonský | 172

Marek Lutonský
COVID-19Koronavirus
Google vymyslel technologii superpřesného GPS. Už ji podporuje Pixel 5 a dorazí i na ostatní telefony

Google vymyslel technologii superpřesného GPS. Už ji podporuje Pixel 5 a dorazí i na ostatní telefony

** Kvalita GPS ve městech občas stojí za starou bačkoru ** Mohou za to odrazy signálu od okolních budov ** Google má jejich 3D model, a tak spolupracuje s výrobci GPS čipů

Jakub Čížek | 46

Jakub Čížek
NavigaceTechnologieGoogle
Čekali jsme skoro šest let. Android Auto jede do Česka i na Slovensko
Lukáš Václavík
Android AutoNavigaceGoogle
Elon Musk podpořil Signal jako náhradu WhatsAppu. Aplikaci okamžitě zavalili uživatelé
Markéta Mikešová
WhatsAppElon MuskFacebook