» Poradna » Programy

Vyhledání v matici a přiřazení záhlaví sloupce

 |   |  Microsoft Windows 7 IE 11.0

Zdravím, potřebuju poradit s funkcí v Excelu. Mám několik sloupců, které mají v záhlaví rok: 2016, 2015,... v každém sloupci je mnoho hodnot... a já potřebuji, abych zadal jednu konkrétní hodnotu a excel mě zpátky vyhodil v jakém sloupci se hodnota nachází (2016, 2015,...) a pokud se hodnota vůbec nevyskytuje, tak aby mě vyhodil "neexistuje"...Zkoušel jsem všechno možný vyhledávací funkce v kombinaci s KDYŽ atd. a vždycky na něčem ztroskotám...Díky moc za odpovědi

Odpovědi na otázku

 | Microsoft Windows 7 Chrome 55.0.2883.92

Nejdřív musíme vědět, jestli se hledaná hodnota může vyskytovat ve více sloupcích zaráz. Pokud ne, je řešení triviální:Sloupec A1=2012;B1=2013...E1=2016G1="hledaná_hodnota"Vzorec bude:=SUMA($A$1:$E$1*($A$2:$E$11=$G$1))a potvrdit CTRL+SHIFT+ENTER (maticový vzorec)$A$1:$E$1 = Řádek záhlaví$A$2:$E$11 = Data$G$1 = Hledaná hodnotaPokud se hledaná hodnota může vyskytovat na více místech, je to trochu problém - výsledků může být víc - a jelikož 1 hodnota = 1 buňka, výsledkem bude více buněk (vektor). V takovém případě bych spíš doporučil zabarvit sloupec pomocí podmíněného formátování.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Vyhledání, Záhlaví


Určitě si přečtěte

Nejlepší příslušenství k počítači. Tipy na osvědčené klávesnice, tiskárny, routery…

Nejlepší příslušenství k počítači. Tipy na osvědčené klávesnice, tiskárny, routery…

** Tipy na klávesnice, myši, routery, tiskárny, sluchátka a další věci k počítačům ** Poradíme, s jakými produkty neuděláte chybu ** Vybíráme jak příslušenství na běžnou práci, tak na hraní her

David Polesný | 22

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

** Strojové učení ještě nepřitáhlo takový zájem jako na začátku prázdnin ** Ne, umělá inteligence nenašla lék na rakovinu ** Naučila se svlékat ženy nejen z plavek

Jakub Čížek | 35



Aktuální číslo časopisu Computer

Test 9 bezdrátových reproduktorů

Jak ovládnout Instagram

Test levných 27" herních monitorů

Jak se zbavit nepotřebných věcí na internetu