» Poradna » Programy

Úprava vzorce

 |   |  Microsoft Windows XP Firefox 52.0

V buňce mám zadaný odkaz pro součet ve tvaru =(D14-D16)-F38+F39Buňka je nastavena jako měna v Kč. Jak mám vzorec doplnit, když potřebuji, aby se při záporné hodnotě (tzn. částce menší než 0) zobrazil text "vyčerpáno"?Zkoušela jsem to s funkcí KDYŽ, ale stále někde dělám chybu. Pozn. Buňky D14, D16, F38 a F39 jsou také výsledkem odkazů (tzn. obsahují rovněž vzorce)Děkuji za pomoc

Odpovědi na otázku

 |   |  Microsoft Windows XP AppleMAC-Safari 5.0

Nestačí nastavit vlastní formát?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Android AppleMAC-Safari 5.0

Stačí.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 52.0

=KDYŽ((D14-D16)-F38+F39<0;"vyčerpáno";(D14-D16)-F38+F39)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Firefox 52.0

Moc děkuji za radu

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Firefox 62.0

V tom vzorci vidím dva problémy, První, pokud je buňka formátována na měnu, nelze zobrazit text, takže změnit formátování buňky. Druhá, text vyčerpáno logicky platí i při částce rovné 0, nejenom při menší jak 0. A ještě ve vzorci, kde se sčítá a odečítá nejsou nutné zátvorky, stačí =KDYŽ(D14-D16-F38+F39<=0;"vyčerpáno";D14-D16-F38+F39).

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Firefox 52.0

Děkuji

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

=KDYŽ((A1-A2)-A3+A4<0;"vyčerpáno";"ne")

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Měna


Určitě si přečtěte

AR není ani po letech žádný trhák. Teď to zkusí Hybri, který svleče vaše kamarádky

AR není ani po letech žádný trhák. Teď to zkusí Hybri, který svleče vaše kamarádky

** Rozšířené realitě i po letech chybí praktické využití ** Selhaly mobilní aplikace i AR brýle ** Floridské studio to proto zkusí přes bizarní erotiku Hybri

Jakub Čížek | 20

Nejlepší aplikace na předpověď počasí: Kde nejlépe zjistit, co zrovna chcete vědět

Nejlepší aplikace na předpověď počasí: Kde nejlépe zjistit, co zrovna chcete vědět

Obecných aplikací na předpověď počasí je nespočet, jenže často skončí jen u základní informace o počasí a nenabídnou odpovědi na řadu praktických otázek. A tak jsme si položili právě několik takových otázek a hledali aplikace či meteoslužby, které nám nejlépe odpoví.

Karel Kilián | 4


Aktuální číslo časopisu Computer

Megatest: nejlepší notebooky do 20 000 Kč

Test 8 levných IP kamer

Jak vybrat bezdrátová sluchátka

Testujeme Android 11