» Poradna » Programy

Tabulka excel 2010

 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Dobré odpoledne, jsa laik, táži se:Mám jednoduchou tabulku, několik řádků. V určitém sloupci sčítám čísla z toho řádku. Např ve sloupci D sčítám hodnoty z A+B+C mám zde nastaven vzorec : =SUMA(A2;B2;C2) potud vše funguje. Ale pokud chci ve sloupci D sečíst hodnoty ze všech řádků, tedy D1+D2+D3+D4+D5+D6 A v 7.řádku ve sloupci D dám vzorec buď ve tvaru : =SUMA(D2:D6) a nebo : =SUMA(D1;D2;D3;D4;D5;D6), nic to nepočítá resp hodnoty to nesečte. Něco dělám špatně,ale kde dělám chybu?Díky za radu,asi to bude triviální,ale bohužel si rady nevím.

Mohlo by vás také zajímat

Odpovědi na otázku

 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Uvedl jsi vzorec pro součet v poli D2. Doufám, že máš vzorce (sloupec D) i v ostatních řádcích, ve kterých pak vytváříš součet v poli D7. Tedy v D1: =SUMA(A1:C1)v D3: =SUMA(A3:C3)v D4: =SUMA(A4:C4)atd až po D6.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

I kdyby to ho tam neměl a pole bylo prázdné, je to jedno. Prostě to přičte nulu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

A to je tak dané a nebo to mohu nějak nastavit ?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

jasně v každém řádku ve sloupci D je vzorec pro součet v daném řádku

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

Nevím, co děláš špatně, tohle musí fungovat. Nemáš to formátované jako text?Ale pokud se ti tam objeví výsledek po stisku F9, možná máš zakázaný automatický přepočet.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

https://uloz.to/file/7CZrLKEwnpni/sum-xlsxPo každém stisku F9 to vygeneruje nová čísla a ta to sečte. Funguje ti to?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

soubor byl smazán

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

Zkus to znovu, bylo to bylo nastavené (neveřejné). Už by to mělo být ok.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

už to jde a ano po stisku F9 to funguje

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

Pokud to funguje až po F9, tak se podívej, zda máš nastavený přepočet na automatiku:https://ctrlv.cz/shots/2019/09/02/JcR1.png

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

F9 funguje ten soubor od tebe na mojí tabulce ne :/

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

Tak nasdílej svoji tabulku. Pokud tam je něco, co nemá být veřejné, nasyp tam nějaké sračky, hlavně aby to nefungovalo stále stejně.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Zkusil jsem vytvořit tabulku znova a už to funguje, tu původní jsem ještě neměl uloženou,ale zajímalo by mne co bylo špatně .

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Je rozdíl pro nějaké další použití napsat vzorec ve tvaru =suma(A1;A2;A3) vs. =suma(A1:A3)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 68.0

Psát SUMA(A1;A2;A3) je naprostá zhovadilost.- Představ si, že potřebuješ vložit do tabulky řádek mezi aktuální druhý a třetí.- Pokud máš zapsán vzorec SUMA(A1:A3), po vložení řádku se změní na SUMA(A1:A4), vše je OK.- Pokud máš vzorec SUMA(A1;A2;A3), změní se na SUMA(A1;A2;A4). Takže nový řádek se v tomto případě do sumy nedostane.Evidentně si ještě s Excelem netykáš, takže doporučuji začít zde: https://office.lasakovi.com/excel/

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Chrome 76.0.3809.132

Excel nepočítá, pokud si myslí, že tam je vložený text místo čísla. Dúvodú múže být více. Někdy stačí např. číslo 1 252 napsat s mezerou, nebo někdy použít čárku jako oddělovač desetinných míst, pokud čeká tečku nebo naopak a podobně. Co konkrétně vadilo ve tvém případě, by se dalo zjistit, jenom pokud bychom mohli prozkoumat Tvúj soubor.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Když vzorce fungují automaticky v řádku ale v tom sloupci ne

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Nastaveno na "automaticky"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Když to narychlo vytvořím v tom sešitu co jsi poslal tak mi to funguje a zajímavé že v tom co mám otevřený s mojí tabulkou ne-e

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Chrome 76.0.3809.132

Doufám, že v tom vzorci nemáš i tu dvojtečku, kterou uvádíš v příkladu. Ja to dělím takto pokud chci součet D1 až D6, přesunu kurzor na D7, stlačím ikonu sumačního tlačítka, to mi většinou správně odhadne i rozsah od D1 až po D6 a stlačím Enter. Součet už funguje. Pokud chci změnit rozsah sumy, zedituju to v tom vzorci. Do editačního režimu se dostanu pomocí F2. Pokud ani potom nebude vzorec fungovat, je možné, že formát buněk není nastavený na obecný nebo číslo ale na např. text.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Ano dvojtečku tam mám zkopíroval jsem ten vzorec sem

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 76.0.3809.132

Také jsem to tak udělal rozsah to odhadlo dobře. Nastavené na "obecné" ale i "číslo" jsem zkoušel a to nefunguje.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Suma, D1


Určitě si přečtěte

Pozor na tyto doplňky pro Chrome a Edge. Mohou obsahovat malware, varuje Avast
Jakub Čížek
MalwareProhlížeče
Vážně dnes ještě někdo krade Adobe? Video můžete stříhat zdarma v Resolve a fotky i vektory zvládne Affinity

Vážně dnes ještě někdo krade Adobe? Video můžete stříhat zdarma v Resolve a fotky i vektory zvládne Affinity

** Kde jsou ty doby, kdy měl skoro každý doma Photoshop ** Photoshop a Premiere Pro od kamaráda nebo z warezu ** Dnes už to nemá smysl, existuje totiž hromada laciných alternativ

Jakub Čížek | 92

Jakub Čížek
Grafický editorStřih videa
Apple Macbook Air M1: testujeme výkon, výdrž, a hlavně kompatibilitu aplikací [průběžně aktualizováno]

Apple Macbook Air M1: testujeme výkon, výdrž, a hlavně kompatibilitu aplikací [průběžně aktualizováno]

** Testujeme Apple Macbook Air s procesorem M1 ** Zajímá nás nejen výkon, ale zejména kompatibilita aplikací ** Článek je průběžně doplňován na základě vašich dotazů

Jiří Kuruc | 209

Jiří Kuruc
Apple