» Poradna » Programy

Spustit makro po zadání hodnoty do buňky

 |   |  Microsoft Windows 7 IE 10.0

Potřebuji v Excelu po zadání hodnoty do buňky spustit automaticky makro, které zkopíruju celou stránku (A4 tabulku) na novou A4 stránku.Prosím o nejednoduší způsob nejsem moc zkušený.Předem děkuji

Odpovědi na otázku

 |   |  Microsoft Windows 7 Firefox 21.0

Třeba takhle:Private Sub Worksheet_Change(ByVal Target As Range) Range("A1:I42").Select Selection.Copy ActiveSheet.Cells(1, 1).Select Sheets("List2").Select ActiveSheet.Cells(1, 1).Select ActiveSheet.Paste ActiveSheet.Cells(1, 1).SelectEnd Sub

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP IE 7.0

Popište trochu více, co chcete:Do které buňky chcete hodnotu zadávat?, bude další postup záviset na tom, co do buňky vložíte?, kam se stránka bude kopírovat - na tentýž list?, na jiný list? nový list?A nebylo by účelnější spouštět makro jinak, než změnou hodnoty buňky?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 10.0

Zadávat hodnotu chci do buňky A27. Po vložení textu do této poslední buňky v tabulce chci, aby se vytvořila stejná strana na stejném listu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 27.0.1453.94

Napiš např. do A30:=KDYŽ($A$27<>""; A1;"")a následně rozkopíruj na patřičný počet řádků a sloupcůPo zadání hodnoty do A27 se zkopírují odpovídající buňky do buněk s nakopírovanými vzorci.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Buňky, Zadání




Určitě si přečtěte

Astronomové objevili daleko za Plutem objekt s extrémní dráhou. Může ukazovat na existenci planety Devět

Astronomové objevili daleko za Plutem objekt s extrémní dráhou. Může ukazovat na existenci planety Devět

** Astronomové objevili daleko za Neptunem těleso 2015 TG387 ** Okolo Slunce se pohybuje po extrémně protáhlé dráze ** Jeho dráha může ukazovat na existenci planety Devět

Petr Kubala | 10

Jak funguje největší akumulátor v Česku: podívejte se do elektrárny Dlouhé Stráně

Jak funguje největší akumulátor v Česku: podívejte se do elektrárny Dlouhé Stráně

** Přečerpávací vodní elektrárna Dlouhé stráně je obdivuhodné technické dílo ** Stejná turbína vyrábí elektřinu i tlačí vodu zpět do horního jezera ** Strojovna elektrárny je zabudována v podzemí

David Polesný | 35

Užijte si poslední změny času: Už od března 2019 můžeme mít trvale letní čas

Užijte si poslední změny času: Už od března 2019 můžeme mít trvale letní čas

** Evropská komise přijala legislativní návrh na zrušení střídaní času ** Možná tak v březnu 2019 přesuneme ručičky hodinek naposledy ** Od toho okamžiku bude permanentně platit letní čas

Karel Kilián | 106

Loopwheels znovu vymyslelo kolo. Místo drátů má v ráfcích kompozitové pružiny, které vylepší komfort jízdy

Loopwheels znovu vymyslelo kolo. Místo drátů má v ráfcích kompozitové pružiny, které vylepší komfort jízdy

** Proč vymýšlet kolo? Protože ho lze vymyslet lépe! ** Kola Loopwheels nabízejí integrované odpružení ** Cílem je poskytnout pohodlnější a klidnější jízdu

Karel Kilián | 14


Aktuální číslo časopisu Computer

Jak vytvořit a spravovat vlastní web

Velký test herních klávesnic a DVB-T2 tunerů

Vše o formátu RAW

Vybíráme nejlepší základní desku