» Poradna » Programy

Spustit makro po zadání hodnoty do buňky

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 4/4
 |   |  Microsoft Windows 7 IE 10.0  |  [46.149.115.---]

Potřebuji v Excelu po zadání hodnoty do buňky spustit automaticky makro, které zkopíruju celou stránku (A4 tabulku) na novou A4 stránku.Prosím o nejednoduší způsob nejsem moc zkušený.Předem děkuji

Odpovědi na otázku

 |   |  Microsoft Windows 7 Firefox 21.0  |  [217.64.0.---]

Třeba takhle:Private Sub Worksheet_Change(ByVal Target As Range) Range("A1:I42").Select Selection.Copy ActiveSheet.Cells(1, 1).Select Sheets("List2").Select ActiveSheet.Cells(1, 1).Select ActiveSheet.Paste ActiveSheet.Cells(1, 1).SelectEnd Sub

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP IE 7.0  |  [194.228.13.---]

Popište trochu více, co chcete:Do které buňky chcete hodnotu zadávat?, bude další postup záviset na tom, co do buňky vložíte?, kam se stránka bude kopírovat - na tentýž list?, na jiný list? nový list?A nebylo by účelnější spouštět makro jinak, než změnou hodnoty buňky?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 10.0  |  [46.149.115.---]

Zadávat hodnotu chci do buňky A27. Po vložení textu do této poslední buňky v tabulce chci, aby se vytvořila stejná strana na stejném listu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 27.0.1453.94  |  [90.180.5.---]

Napiš např. do A30:=KDYŽ($A$27<>""; A1;"")a následně rozkopíruj na patřičný počet řádků a sloupcůPo zadání hodnoty do A27 se zkopírují odpovídající buňky do buněk s nakopírovanými vzorci.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Buňky, Zadání



Určitě si přečtěte



Aktuální číslo časopisu Computer

26 procesorů v důkladném testu

Zhodnotili jsme 18 bezdrátových reproduktorů

Jak fungují cash back služby?

Pohlídejte své děti na internetu