» Poradna » Windows (a jiné OS)

Problém s dpkg a nemožností instalovat na Ubuntu

 |   |  Microsoft Windows 7 Chrome 48.0.2564.109

Zdravím, vyskytl se mi problém na serveru, kde mi běží ubuntu 12.04.Když jsem klasicky aktualizoval pomocí - sudo apt-get update a následně apt-get dist-upgrade tak mi to vyhodilo :root@server:~# apt-get dist-upgradeČtu seznamy balíků… HotovoVytvářím strom závislostíČtu stavové informace… HotovoPro opravení můžete spustit „apt-get -f install“.Následující balíky mají nesplněné závislosti: linux-generic-pae : Závisí na: linux-image-generic-pae (= 3.2.0.94.108) ale 3.2.0.97.113 je nainstalovánlinux-headers-generic-pae : Závisí na: linux-headers-3.2.0-94-generic-pae ale není nainstalovanýE: Nesplněné závislosti. Zkuste použít -f.Když jsem zkusil nainstalovat daný balíček přímo:root@server:~# apt-get install linux-headers-3.2.0-94-generic-paeČtu seznamy balíků… HotovoVytvářím strom závislostíČtu stavové informace… HotovoPro opravení následujících můžete spustit „apt-get -f install“:Následující balíky mají nesplněné závislosti: linux-generic-pae : Závisí na: linux-image-generic-pae (= 3.2.0.94.108) ale 3.2.0.97.113 se bude instalovatE: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení). Čili když jsem použil apt-get -f install, tak mi to vypsalo toto:Čtu seznamy balíků… HotovoVytvářím strom závislostíČtu stavové informace… HotovoOpravuji závislosti… HotovoNásledující balíky byly nainstalovány automaticky a již nejsou potřeba:aspell-en libtalloc2 libjs-jquery-ui linux-image-3.2.0-84-generic-pae php-mail-mime linux-headers-3.2.0-93-generic-pae linux-headers-3.2.0-88-generic-pae erlang-erl-docgen erlang-inets erlang-asn1 aspell erlang-webtool libicu48 erlang-snmp erlang-syntax-tools linux-headers-3.2.0-90-generic-pae linux-headers-3.2.0-85-generic-pae erlang-edoc php-net-socket erlang-inviso erlang-diameter linux-headers-3.2.0-72 linux-headers-3.2.0-74 linux-headers-3.2.0-80 linux-headers-3.2.0-75 linux-headers-3.2.0-76 linux-headers-3.2.0-82 linux-headers-3.2.0-77 linux-headers-3.2.0-83 linux-headers-3.2.0-84 linux-headers-3.2.0-79 linux-headers-3.2.0-90 linux-headers-3.2.0-85 linux-headers-3.2.0-91 linux-headers-3.2.0-86 linux-headers-3.2.0-92 linux-headers-3.2.0-87 linux-headers-3.2.0-93 linux-headers-3.2.0-88 linux-headers-3.2.0-89 linux-headers-3.2.0-82-generic-pae linux-headers-3.2.0-77-generic-pae erlang-mnesia erlang-parsetools erlang-os-mon linux-headers-3.2.0-72-generic-pae linux-image-3.2.0-90-generic-pae linux-image-3.2.0-85-generic-pae john-data linux-headers-3.2.0-89-generic-pae tdb-tools erlang-eunit linux-image-3.2.0-82-generic-pae php-auth-sasl linux-headers-3.2.0-91-generic-pae linux-headers-3.2.0-86-generic-pae erlang-corba samba-common-bin erlang-xmerl erlang-tools linux-headers-3.2.0-83-generic-pae dictionaries-common php-net-smtp erlang-percept php5-pspell erlang-dev linux-headers-3.2.0-80-generic-pae linux-headers-3.2.0-75-generic-pae linux-image-3.2.0-93-generic-pae linux-image-3.2.0-88-generic-pae linux-image-3.2.0-91-generic-pae linux-image-3.2.0-86-generic-pae libwbclient0 erlang-ic erlang-crypto linux-image-3.2.0-83-generic-pae erlang-odbc erlang-nox linux-headers-3.2.0-92-generic-pae linux-headers-3.2.0-87-generic-pae php5-intl libtommath0 php-auth erlang-ssh samba-common erlang-ssl erlang-docbuilder linux-headers-3.2.0-84-generic-pae linux-headers-3.2.0-79-generic-pae libodbc1 erlang-runtime-tools tinymce auth-client-config linux-headers-3.2.0-76-generic-pae chkrootkit john linux-headers-3.2.0-74-generic-pae libaspell15 linux-image-3.2.0-89-generic-pae linux-image-3.2.0-92-generic-pae linux-image-3.2.0-87-generic-pae php-mail-mimedecode erlang-base erlang-public-keyPro jejich odstranění použijte „apt-get autoremove“.Následující extra balíky budou instalovány: linux-generic-pae linux-headers-3.2.0-98 linux-headers-3.2.0-98-generic-pae linux-headers-generic-pae linux-image-3.2.0-98-generic-pae linux-image-generic-pae Navrhované balíky: fdutils linux-doc-3.2.0 linux-source-3.2.0 linux-toolsNásledující NOVÉ balíky budou nainstalovány: linux-headers-3.2.0-98 linux-headers-3.2.0-98-generic-pae linux-image-3.2.0-98-generic-paeNásledující balíky budou aktualizovány: linux-generic-pae linux-headers-generic-pae linux-image-generic-pae3 aktualizováno, 3 nově instalováno, 0 k odstranění a 55 neaktualizováno. 2 instalováno nebo odstraněno pouze částečně.Potřebuji stáhnout 51,2 MB archivů. Po této operaci bude na disku použito dalších 182 MB. Chcete pokračovat [Y/n]? yMám:1 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-3.2.0-98-generic-pae i386 3.2.0-98.138 [38,6 MB] Mám:2 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-generic-pae i386 3.2.0.98.114 [1 732 B] Mám:3 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-image-generic-pae i386 3.2.0.98.114 [2 660 B] Mám:4 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-3.2.0-98 all 3.2.0-98.138 [11,7 MB] Mám:5 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-3.2.0-98-generic-pae i386 3.2.0-98.138 [981 kB] Mám:6 http://cz.archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-generic-pae i386 3.2.0.98.114 [2 610 B] Staženo 51,2 MB za 15s (3 317 kB/s) Traceback (most recent call last): File "/usr/bin/apt-listchanges", line 237, in main() File "/usr/bin/apt-listchanges", line 48, in main debs = apt_listchanges.read_apt_pipeline(config) File "/usr/share/apt-listchanges/apt_listchanges.py", line 83, in read_apt_pipeline return map(lambda pkg: filenames[pkg], order) File "/usr/share/apt-listchanges/apt_listchanges.py", line 83, in return map(lambda pkg: filenames[pkg], order) KeyError: 'linux-headers-generic-pae' Vybírám dosud nevybraný balík linux-image-3.2.0-98-generic-pae. (Čtu databázi … nyní je nainstalováno 597333 souborů a adresářů.) Rozbaluji linux-image-3.2.0-98-generic-pae (z …/linux-image-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb) … Done. dpkg: chyba při zpracovávání /var/cache/apt/archives/linux-image-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb (--unpack): nelze vytvořit „/lib/modules/3.2.0-98-generic-pae/kernel/drivers/input/evbug.ko.dpkg-new“ (při zpracování „./lib/modules/3.2.0-98-generic-pae/kernel/drivers/input/evbug.ko“): Na zařízení není volné místo Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem. dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE)) Examining /etc/kernel/postrm.d . run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-98-generic-pae /boot/vmlinuz-3.2.0-98-generic-pae run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-98-generic-pae /boot/vmlinuz-3.2.0-98-generic-pae Připravuji nahrazení linux-image-generic-pae 3.2.0.97.113 (pomocí …/linux-image-generic-pae_3.2.0.98.114_i386.deb) … Rozbaluji náhradu linux-image-generic-pae … Vybírám dosud nevybraný balík linux-headers-3.2.0-98. Rozbaluji linux-headers-3.2.0-98 (z …/linux-headers-3.2.0-98_3.2.0-98.138_all.deb) … dpkg: chyba při zpracovávání /var/cache/apt/archives/linux-headers-3.2.0-98_3.2.0-98.138_all.deb (--unpack): nelze vytvořit „/usr/src/linux-headers-3.2.0-98/arch/cris/include/arch-v32/mach-fs/mach/hwregs/marb_bp_defs.h.dpkg-new“ (při zpracování „./usr/src/linux-headers-3.2.0-98/arch/cris/include/arch-v32/mach-fs/mach/hwregs/marb_bp_defs.h“): Na zařízení není volné místo Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem. dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE)) Vybírám dosud nevybraný balík linux-headers-3.2.0-98-generic-pae. Rozbaluji linux-headers-3.2.0-98-generic-pae (z …/linux-headers-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb) … dpkg: chyba při zpracovávání /var/cache/apt/archives/linux-headers-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb (--unpack): chyba při vytváření adresáře „./usr/src/linux-headers-3.2.0-98-generic-pae/include/config/snd/atiixp“: Na zařízení není volné místo Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem. dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE)) Při zpracování nastaly chyby: /var/cache/apt/archives/linux-image-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb /var/cache/apt/archives/linux-headers-3.2.0-98_3.2.0-98.138_all.deb /var/cache/apt/archives/linux-headers-3.2.0-98-generic-pae_3.2.0-98.138_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) Jelikož se píše, že na zařízení není místo, tak jsem si vypsal místo na discích:root@server:~# df -hSouborový systém Velikost Užito Volno Uži% Připojeno do/dev/md0 9,2G 6,4G 2,4G 74% /udev 3,0G 12K 3,0G 1% /devtmpfs 606M 352K 606M 1% /runnone 5,0M 0 5,0M 0% /run/locktmpfs 3,0G 0 3,0G 0% /run/shm/dev/md1 184G 54G 121G 31% /home/dev/md2 33G 3,3G 29G 11% /var Můžete mi poradit, co můžu udělat, abych mohl normálně dále fungovat a instalovat aktualizace, nebo nové balíčky?Díky všem za reakce

Odpovědi na otázku

 |   |  Linux Chrome 48.0.2564.82

Podle výpisu místa máš dost..Polož dotaz raději zde http://forum.ubuntu.cz/index.php šance že se dočkáš odpovědi je mnohokrát větší než tady.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Firefox 44.0

Mno, Ubuntu jsem měl naposled 11.04, ale kontroly závislostí v Mintu píšu takhle:"sudo apt-get install -f", tobě to tam píše: „apt-get -f install“Ale na forumu Ubuntu, jak tě směruje Juwa, najdeš, co potřebuješ, nebo na http://www.abclinuxu.cz/

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 48.0.2564.109

Warning : OfftopicPreco preboha ziveho mas ten server po Cesky?!Teraz mas nejaky problem a nemozes sa dogooglit k rieseniu.Server OS by mal byt VZDY in English.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 48.0.2564.109

protože předchozí správci to tak nainstalovali a tento server se může měnit jen v určitém období, kdy na něm není provoz, což teď není

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 48.0.2564.109

Jasne, chapem, sorry za offtopic a prajem vela zdaru

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Unknown Mozilla 44.0

Najvyšší čas na apt-ger dist-upgrade , ak tomu nič nebráni. .

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 48.0.2564.109

Myslíš že jsem dist-upgrade nezkoušel? Čtu seznamy balíků… HotovoVytvářím strom závislostíČtu stavové informace… HotovoPro opravení můžete spustit „apt-get -f install“.Následující balíky mají nesplněné závislosti: linux-generic-pae : Závisí na: linux-image-generic-pae (= 3.2.0.94.108) ale 3.2.0.98.114 je nainstalován linux-headers-generic-pae : Závisí na: linux-headers-3.2.0-94-generic-pae ale není nainstalovanýE: Nesplněné závislosti. Zkuste použít -f.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Firefox 44.0

reboot a nabootuj jadro 3.2.0.98, a staré jadrá odinštaluj.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Firefox 45.0

Dnes nie je pondelok ale poondelok, lebo sa vsetko poondi.Napr. tu som slepy..

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Chrome 48.0.2564.95

But te lasky a preinstaluj to na x86_64...

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Linux, Ubuntu, Image, Archives, Main, Updates, Roura, Volné místo, Arch, Zpracovávání, Strom, Parts, Souborový systém, MIME, ODBC


Určitě si přečtěte

Nejlepší notebooky do 20 000 Kč. Tipy, co se dnes vyplatí koupit

Nejlepší notebooky do 20 000 Kč. Tipy, co se dnes vyplatí koupit

** S cenou do 20 tisíc lze vybrat solidní notebook na práci i hry ** Přenosné notebooky nabídnou i kovová těla a rychlý hardware ** Na hraní se hodí více peněz, ale na použitelný základ dvacet tisíc stačí

Tomáš Holčík, David Polesný | 49

10 mýtů a polopravd o bateriích, kterým možná ještě věříte

10 mýtů a polopravd o bateriích, kterým možná ještě věříte

** Kolem baterií a akumulátorů koluje řada mýtů, nepravd a polopravd ** Dnes vám devět z nich zkusíme vyvrátit na základě faktů ** Většina z nich totiž neplatí pro moderní lithiové baterie

Karel Kilián, David Polesný | 102



Aktuální číslo časopisu Computer

Test 9 bezdrátových reproduktorů

Jak ovládnout Instagram

Test levných 27" herních monitorů

Jak se zbavit nepotřebných věcí na internetu