» Poradna » Programy

Microsoft excel- funkce

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 6/6
 |   |  Microsoft Windows Vista Chrome 21.0.1180.83  |  [90.178.221.---]

Dobrý den všem, chtěl jsem se zeptat výhradně odborníka, který by byl tak laskav a mírně polopatě mi vysvětlil, jak mám postupovat při tomto problému: V excelu (dokument o pěti stránkách-dnech), mám tabulku, kde jsou v řádcích napsány třídy (1.A, 2.A, 1.B, 2.B, atd..) a za třídami mám napsán rozvrh od 1. hodiny, až do 10. hodiny= deset sloupců. Když označím např. na stránce: úterý: 3. a 4. hodinu (tyto sloupce, u všech tříd, zabarvím je žlutě), potřebuji, aby se každé třídě tyto dvě hodiny (např u 1.B matematika (mat) a angličtina (aj)) zabarvily V CELÉM TÝDNU (na všech stránkách dokumentu, ale matematika a angličtina jen třídě 1.B, (např. u 2.BG čeština a fyzika). Jde o to, aby nebyli studenti ošizeni např. o deset hodin češtiny a jinak vše měli. Ale když pak budu muset označit a vypsat zkoušku na tyto, již obarvené buňky (hodiny), chtěl bych aby se mi při druhém označení zabarvily jinak, takže když je zabarvím modrou, chci aby se v celém týdnu zabarvily modře... (takže když buňka bude zelená, i ostatní zelené), atd.Velice děkuji za brzké odpovědi a PODROBNÉ RADY! L.

Odpovědi na otázku

 |   |  Microsoft Windows 7 Chrome 21.0.1180.83  |  [90.180.5.---]

Nechápu ty barvy Rozložení tříd a předmětů je mi jasné Potřeboval bych popsat podstatu vybarvování předmětů. Proč se ty předměty vybírají obarvováním? Když bude mít třeba v té 3. a 4. hodině matematiku více tříd, tak se má matematika vybarvit více třídám nebo tento případ nemůže nastat?Mně přijde ten výběr 3. a 4. hodiny pro všechny třídy hrozně náhodný. Poč to takto vybíráš? K těm zkouškám. Když vybereš předmět, chceš ho obarvit modrou všem třídám v celém týdnu?Obecně bych vyhodnocování dělal podle jiných než barevných podmínek (textové, číselné, logické, ..). A obarvoval bych to následně podle výsledků podmínek.Víc k tomu teď nedám. Vzorek dat by se hodil.Bavíme se o Excelu 2010?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows Vista Chrome 21.0.1180.83  |  [90.178.221.---]

Jde o to, že když bude mít třída 3.B: 3. a 4. hodinu v pondělí matematiku a češtinu, tak aby se mi v dokumentu na následující stránce obarvily všechny matematiky a češtiny jen u té třídy 3.B (takže reakce jen na řádky).3.A 3. a 4. hodinu v pondělí hudební výchovu a tělocvik, tak aby se mi v dokumentu na následujících stránkách (úterý, středa, čtvrtek, pátek) obarvily všechny hudební výchovy a tělocviky jen u té třídy 3.A atd...Potřebuji nějakou funkci na reakci (obarvím políčko C8 (HV), tak chci aby se mi obarvily všechna políčka s HV, např. G8 na druhé stránce, na čtvrté D8 (jen řádku osm=jeden řádek=jedna třída, jedna stránka=jeden den).L.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 21.0.1180.83  |  [90.180.5.---]

"Potřebuji nějakou funkci na reakci (obarvím políčko C8 (HV), tak chci aby se mi obarvily všechna políčka s HV"Takové funkce excel nemá. Pokud bys to chtěl mermomocí řešit přes barvy, tak by sis musel napsat uživatelské funkce pomocí VBA, jak jsem radil tady http://www.zive.cz/poradna/vzorce-v-excelu/s... Jinak já bych vytvořil nový list, třeba Kriteria. Ten by obsahoval v prvním sloupci Třídu, v druhém sloupci Předmět1, ve třetím sloupci Předmět2.Pak bych na listech Pondělí až Pátek nastavil podmíněné formátování na oblast předmětů se 2 pravidly:Formátovat pouze buňky obsahující, hodnota buňky je rovna=SVYHLEDAT($A2;Kriteria!$A:$C;2;0) pro první předmět, nastavíš požadovaný formát=SVYHLEDAT($A2;Kriteria!$A:$C;3;0) pro druhý předmět, nastavíš požadovaný formátPro Zkoušku vytvoříš obdobně další pravidlo.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows Vista Chrome 21.0.1180.83  |  [89.24.237.---]

Mohl bys mi to prosím trochu více upřesnit, nejsem technický talent, takže bych to potřeboval od toho, jakmile zadám PODMÍNĚNÉ FORMÁTOVÁNÍ, SPRÁVA PRAVIDEL, NOVÉ PRAVIDLO, FORMÁT BUŇKY POUZE OBSAHUJÍCÍ, pak hodnota buňky je rovna, formát nastavím barvu a pak nevím, jaká políčka mám vybrat...

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 21.0.1180.83  |  [90.180.5.---]

Ve všech listech dnů jsou 3 stejná pravidla. SVYHLEDAT se liší jen číslem sloupce, ve kterém vyhledává. Předmět1 a Předmět2 mají různé barvy, abys to viděl. Zkoušku jsem jen nahodil, nejsem si jistý, že rozumím zadání. Třídy na listu Kriteria jsou schválně přeházené, aby bylo vidět, že se to vybírá podle třídy - asi si to setřídíš.http://imageshack.us/photo/my-images/269/excel... http://imageshack.us/photo/my-images/222/excel... http://imageshack.us/photo/my-images/94/excelu... Zvětši si to lupou.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Firefox 14.0.1  |  [65.197.242.---]

Jestli to chceš hrotit, napiš si makro, ale bude to celkem náriočná věc.Ale pokud jsem to pochopil dobře, požaduješ celkem komplexní aplikaci na rozvrhy a tady už s Excelem nevystačíš. Poohlédni se po něčem jiném.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Matematika, Fyzika, Microsoft Excel, Angličtina, Rozvrh, Studenti



Určitě si přečtěte


Čína vyvíjí ohromná hejna tisícovek malých dronů

Čína vyvíjí ohromná hejna tisícovek malých dronů

** Vývoj hejnové inteligence pro drony v Číně nabírá na rychlosti ** Velká hejna dronů mají podle odborníků značný potenciál pro vojenské využití i pro bezpečnostní aplikace ** Číňané se navíc s drony neomezuje jenom na zemský povrch a okolí, ale poohlížejí se i po vesmíru

11.  1.  2018 | Stanislav Mihulka | 3

Genetika a příjmení: Unikátní možnost získat test Y-DNA zdarma a dozvědět se o svých předcích

Genetika a příjmení: Unikátní možnost získat test Y-DNA zdarma a dozvědět se o svých předcích

** Projekt Genetika a příjmení hledá shody mezi osobami se stejným příjmením ** Využívá k tomu testování DNA na chromozomu Y ** Výsledky testu můžete účastí v projektu získat zdarma

11.  1.  2018 | Marek Lutonský | 3


Aktuální číslo časopisu Computer

Zachraňte nefunkční Windows

Jak nakupovat a prodávat kryptoměny

Otestovali jsme konvertibilní notebooky

Velký test 14 herních myší