» Poradna » Programy

Jake JRE podporuje Pocket PC?

 |   |   |  [81.27.198.---]

Ahoj, chci se zeptat jaky virtualni stroj javy podporuje Pocket PC/Palm. Je to Java Micro Edition nebo J2SE? Dale znate nejake vhodne emulatory pro vyse zminene platformy? Diky za odpovedi.

Odpovědi na otázku

 |   |   |  [62.240.168.---]
 |   |   |  [81.27.198.---]

Nejake dalsi tipy?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | 

nejlepší je asi WebSphere Everyplace Micro Environment (http://www-306.ibm.com/software/wireless/weme/). Pro Palm i PocketPC mají implementované J2ME CLDC 1.0 MIDP 2.0, pro PocketPC, mají navíc ještě J2ME CDC 1.0 Personal Profile 1.0, což je výrazně mocnější. Je pro to i kompletní vývojové prostředí (WebSphere Studio Device Developer).

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |   |  [62.240.168.---]

to nic moc podle toho co píšeš, na tom co jsem poslal já jde i částečně JSE (awt a dokonce i swing) a kamrádovi to běží v pohodě

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | 

Na mysaifu jsem taky narazil, ale projekt, na kterém pracuje jeden vývojář, je v alfa statusu ve verzi 0.2.3, vůbec se neuvádí jaká verze J2SE to má vlastně být (1.2, 1.3, 1.4 nebo 1.5), na screenshotech je přitom vidět java specification version 1.1, prostě to na mě působí zcela nedůvěryhodně, podle mě to nemá šanci, napsat implementaci J2SE pro PPC prostě jeden člověk prostě nemůže zvládnout.

Takže v tomto případě jednoznačně dávám přednost implementaci J2ME CDC 1.0 PP 1.0 od IBM. Nedávno také vydal NSICom CrEme 4, což je další implementace J2ME CDC 1.0 PP 1.0.

Navíc dnešní PDA jsou příliš slabá (pamětově i výkonově), aby na nich rozumně běžela nějaká rozumně nová verze J2SE, tj. alespoň 1.3.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Pocket, Palm



Určitě si přečtěte


Aktuální číslo časopisu Computer

Test 6 odolných telefonů a 22 powerbank

Srovnání technologií QLED a OLED

Měřte své sportovní výkony

Sady pro chytrou domácnost