» Poradna » Programy

Excel vzorec

 |   |  Microsoft Windows 8 Chrome 32.0.1700.107

Ahoj, jakým způsobem zapíšu vzorec, když při rozdílů dvou časů, kdy A1 je příchod a B1 odchod, potřebuji určit že pro menší a rovný čas "00:30" se zapíše hodnota "00:30" a pro jakýkoliv čas nad půl hodiny se vypíše prostě jen rozdíl časů... Myslel jsem, že vzorec bude takto:=KDYŽ(B1-A1<="00:30";"00:30";B1-A1) Díky za radu

Mohlo by vás také zajímat

Odpovědi na otázku

 |   |  Microsoft Windows 7 IE 11.0

Vzorec by vypadal =KDYŽ(B1-A1<=0,02;"00:30";B1-A1).Háček je v tom, že vzorec takto napsaný ti zapíše 00:30 jako text, tudíž se s ním dále nedá počítat. takže pokud potřebuješ pak nějaké počítání musíš to ještě vynásobit jedničkou.=KDYŽ(B1-A1<=0,02;"00:30";B1-A1)*1

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Nebo chceš-li to úplně přesně, pak 30 minut = 30/(24*60)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Prosím - pri akých časových hodnotách je B1-A1<=0,02; a pri "00:30"*1 mám výsledok #HODNOTA!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 9.0

Někde jsi udělal chybu, nahraj někam (třeba na uloz.to) vzorek, snadněji/rychleji se to chledá na příkladu

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Chrome 32.0.1700.107

Hodnota 0,02 je čas 0:28:48

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8 Chrome 32.0.1700.107
 |   |  Microsoft Windows 8 Chrome 32.0.1700.107

A jak byste upravil nefungující rozšířený vzorec: =KDYŽ(M4="víkend";"";KDYŽ(M4="dovolená";"";KDYŽ(M4="placené volno";"";KDYŽ(A(M4="pracovní den";G4-F4<=0,02);"00:30";G4-F4)*1)))na obdobnou situaci? opět má být menší doba než půl hodiny zapsáná jako půlhodinová a vše co je nad půl hodiny má být rozdílem odchodu s příchodem...Díky

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Jestli správně chápu vzorec, pak ti jde o to, aby se to počítal pouze v případě, že jde o pracovní den. Pak nemá cenu kombinací "když" nechávat "".Nechal bych jen:=KDYŽ(M4="pracovní den";KDYŽ(B4-A4<=30/1440;"00:30";B4-A4)*1;"")Ale pokud může nastat i jiná situace, kdy to má počítat pak bych ještě přidal funkci NEBO.Takže by to vypadalo:=KDYŽ(NEBO(M4="pracovní den";M4="cojavim");.....pokračování je stejné

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Vzorec, Příchod, Odchod, Rovný


Určitě si přečtěte

Elon Musk už není nejbohatší na světě. Během jediného dne přišel o 324 miliard korun
Karel Kilián
Jeff BezosTesla MotorsElon Musk
Týden Živě: On fakt dnes ještě někdo stahuje filmy z Ulož.to?

Týden Živě: On fakt dnes ještě někdo stahuje filmy z Ulož.to?

** Kauza Ulož.to a proč my dva už (moc) newarezíme ** Windows 10X existují, ale nabízí se otázka proč ** Nissan ukázal vizi kanceláře v podobě karavanu

Jakub Čížek, Vladislav Kluska | 152

Jakub ČížekVladislav Kluska
Týden ŽivěVideo
Volitelná aktualizace Windows 10 opravila několik chyb, způsobila ale další problémy
Karel Kilián
Windows UpdateAktualizaceWindows 10
Japonská MANA může být 80× výkonnější než sebelepší tranzistorový procesor

Japonská MANA může být 80× výkonnější než sebelepší tranzistorový procesor

** Tranzistory současných počítačů vyzařují při přepínání teplo ** Na Tokijské univerzitě proto vyvíjejí adiabatické procesory ** Využívají supravodivost a jsou 80× úspornější

Jakub Čížek | 48

Jakub Čížek
TranzistoryProcesoryTechnologie
Finanční správa tento měsíc spustí Moje Daně. Přiznání má být hračka
Lukáš Václavík
eIdentitaČeskoeGovernment
9 nejlepších českých webů, kde lze stáhnout filmy a seriály

9 nejlepších českých webů, kde lze stáhnout filmy a seriály

** Když selžou legální zdroje, můžete se zkusit obrátit na služby pro stahování souborů ** Ulož.to není zdaleka jediné, které nabízí videoobsah ke stažení ** Konkurenční služby nabízí levnější placené účty

redakce | 112

redakce
TipyHudba, filmy, seriályWeb
Nejlepší notebooky do 20 000 Kč. Tipy, co se dnes vyplatí koupit

Nejlepší notebooky do 20 000 Kč. Tipy, co se dnes vyplatí koupit

** S cenou do 20 tisíc lze vybrat solidní notebook na práci i hry ** Přenosné notebooky nabídnou i kovová těla a rychlý hardware ** Možná největší problém je nedostupnost, nejžádanější kusy jsou vyprodané

David Polesný | 36

David Polesný
VánoceNotebooky
Jak najít hranice území obcí a okresů, abyste věděli, kde se můžete pohybovat
Filip KůželJakub Čížek
KoronavirusMapy