» Poradna » Programy

Excel vzorec pro bodování na základě přidělených hodnot

 |   |  Microsoft Windows 10 Chrome 74.0.3729.131

Zdravím, ráda bych požádala o pomoc při tvoření vzorce v excelu. Chci vytvořit seznam osob a k nim do kolonek vkládat jejich výsledky. Například Honza skočí 2 metry a patří do kategorie M1 a na základě této kategorie mu systém vypočítá 3 body. Kateřina skočí také 2 metry, ale je zařazena do kategorie M4, takže jí systém má vypočítat bodů 5.Můžete mi prosím pomoci s vytvořením takového vzorce? Již mám v excelu bokem vytvořené podmínky pro bodování, tzn v kat M1 jsou 1,9 - 2,1 metry za 3 body a 2,2 - 2,4 metru je za 4 body..Mockrát děkuji!

Odpovědi na otázku

 |   |  Microsoft Windows 10 Firefox 66.0

Copak - domácí úkol?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.131

Vidím, že jste omezen pouze k přidáváním zbytečných komentářů, ale sám nevíte oč jde Vy už máte své domácí úkoly hotové? Nenechávejte je na neděli večer!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 10 Firefox 66.0

IQ80 + Google Sergio Engino = result.Je to tak neskutecne tezke, co?MAX a VLOOKUP/MATCH.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP AppleMAC-Safari 5.0

Tak si ještě doplň podmínky pro další M kategorie a můžeš počítat =když()...

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.131

Je to opravdu vzorec když? Potřebuji aby pokud má někdo výsledek 2,05, tak se to přiřadilo k rozmezí 1,9 - 2,1. Toto rozmezí stačí, když si vedle pouze napíši opravdu jen v klasické formě 1,9 - 2,1 a do políčka vedle 3 body? Potřebuji na sebe napojit spoustu různých polí a už se v tom množství úplně ztrácím. Excel jsem měla naposledy na ZŠ . Děkuji.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP AppleMAC-Safari 5.0

Ano, na tohle funkce KDYŽ úplně stačí, zhruba jak píše unregistered. Jen je tam potřeba ještě doplnit podmínku pro výběr kategorie M1 až M4.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.134

nemůžu dát všechna vajíčka do jednoho košíku, v některých učebnicích lze nalézt větičku nějakého podobného znění - tento důkaz ponechávám na laskavém čtenáři, zbytek si laskavý čtenář jistě dopočítá sám...

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.134

např. =KDYŽ(A31<1,9;1;KDYŽ(A(A31>=1,9;A31<=2,1)*0,1;3;5))při hodnotě menší než 1,9 se přiřadí 1 bod, pro hodnoty 1,9 - 2,1 včetně se přiřadí 3 body, nad 2,1 pak 5 bodů

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.134

znaky *0,1 do toho vzorce nepatří, správně tedy=KDYŽ(A1<1,9;1;KDYŽ(A(A1>=1,9;A1<=2,1);3;5))

Souhlasím  |  Nesouhlasím  |  Odpovědět
avatar
 | Linux Chrome 74.0.3729.134

pokud to nezbytně nemusí být všechno narvané v jednom, tak bych si vyrobil pomocné sloupce s kategoriemi a koeficienty a pak použil klasické kombinace logických funkcí typu "IF" a klasické aritmetiky.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 74.0.3729.108

Musite pouzite funkce INDEX a MATCH.Toto je vzorec:INDEX($I$1:$N$5,MATCH(B2,$I$1:$I$5,0),MATCH(C2,$I$1:$N$1))Predpokladam, ze mate vedle v nejake tabulce $I$1:$N$5 kategorie v radcich a dolni hranice intervalu ve sloupcich.Kategorie u vysledku je ve sloupci B2 a vysledek ve sloupci C2.Funkce INDEX vybira hodnotu v tabulce $I$1:$N$5 na zaklade nalezene kategorie ve sloupci I, to je vzorec MATCH(B2,$I$1:$I$5,0), ta 0 na konci znamena presne vyhledani. Tim urcite radek kategorie. Sloupec se najde pomoci MATCH(C2,$I$1:$N$1), zde chybi 0, protoze se vyhledava nejblizsi vysledek v serazenem poli. Nejak takhle by mela ta tabulka vypadat: 0 1.9 2.1 2.2m1 1 2 3 4m2 2 3 4 5m3 3 4 5 6m4 4 5 6 7

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Kategorie


Určitě si přečtěte



Aktuální číslo časopisu Computer

Velký test fotolabů

Oklamali jsme rozpoznání obličeje

13 tipů pro rychlejší Wi-Fi

Test NVMe SSD 500 GB