» Poradna » Programy

Excel-výpočet podílu ranní a noční z času OD-DO v práci

 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

Dobrý den, prosím o pomoc se vzorcem v Excelu. Mám dva sloupce, v jednom příchod do práce, v druhém odchod, oba časy jsou naprosto nepravidelné. Potřebuji připojit dva sloupce, kde v prvním se mi vypočte ze zadaných hodnot délka v hodinách a minutách v rámci ranní (6:00-22:00) a v druhém délka noční (0:00-6:00 a 22.00-24:00). Děkuji

Odpovědi na otázku

 |   |  Microsoft Windows 10 Firefox 72.0

Nechce se mi to řešit celé, takže jen inspirace:A1 - příchodB2 - odchodPočítal bych tři sloupce:Noční od půlnoci do 6 hod: =IF(A1<=TIMEVALUE("06:00");A1;TIMEVALUE("00:00"))Denní: kombinace 4 různých variant, nechám už na toběNoční 22 až půlnoc: =IF(B1>TIMEVALUE("22:00");B1-TIMEVALUE("22:00");TIMEVALUE("0:00"))Není to kompletní řešení zahrnující všechny možnosti, je to jen úvodní INSPIRACE, jak by se to dalo řešit.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 10 Chrome 80.0.3987.116

Píšete si docházku ručně, nebo se Vám to tam odněkud "sype". Pak by totiž mohl být příchod v jednom dni a odchod v druhém, že?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

Dobrý den,příchod a odchod se vyplňuje ručně a překlápění do dalšího dne řešit nepotřebuji, tedy pouze spočítat v rámci jednoho dne, 24 hodin.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

ty výpočty jsou docela složité je třeba brát to že směny a časy můžou mezi sebou mít přesahy, pokud nebudu ošetřovat časy před a po směně, tak ty zákloadní výpočty jsou následujícívýpočet denní je to po 2 řádcích jádro denní směny + přesah příchodu na N + přesah odchodu z N=KDYŽ(A(A2>0;A2<B2);B2-A2-KDYŽ(A2<ČASHODN("6:00");"6:00"-A2;0)-KDYŽ(B2>ČASHODN("22:00");B2-"22:00";0);0)+KDYŽ(A(A2>ČASHODN("6:00");NEBO(A2>B2;B2=0));KDYŽ(A2<ČASHODN("22:00");"22:00"-A2;0))+KDYŽ(A(B2<ČASHODN("22:00");NEBO(A2>B2;A2=0));KDYŽ(B2>ČASHODN("6:00");B2-"6:00";0))výpočet noční opět po 2 řádcích přesahy D, příchod na N + Odchod z N=KDYŽ(A(A2>0;A2<B2);B2-A2-KDYŽ(A2<ČASHODN("6:00");"6:00"-A2;0)-KDYŽ(B2>ČASHODN("22:00");B2-"22:00";0);0)+KDYŽ(A(A2>ČASHODN("6:00");NEBO(A2>B2;B2=0));KDYŽ(A2<ČASHODN("22:00");"22:00"-A2;0))+KDYŽ(A(B2<ČASHODN("22:00");NEBO(A2>B2;A2=0));KDYŽ(B2>ČASHODN("6:00");B2-"6:00";0))fungovalo mi to na vzorové tabulcePříchod Odchod 5:30:00 15:30:00 9:30:00 0:30:006:30:00 15:30:00 9:00:00 0:00:0016:00:00 22:30:00 6:00:00 0:30:0019:00:00 3:00:00 2:00:0020:00:00 6:10:00 2:10:00 8:00:00 6:10:00 0:10:00 6:00:00 0:00:00 0:00:0020:00:00 23:30:00 2:00:00 1:30:00

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

měl jsem dlouhou chvíli při čekání na reinstal PC :D

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

Děkuji, vyzkouším :)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 80.0.3987.116

u té vzorové tabulky 4-6 řádek jsou noční na 4ř. je příchod + výpočty na 6ř. je odchod + výpočty

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Příchod, Odchod


Určitě si přečtěte

Jak nahradit webkameru: jde to telefonem, zadarmo a s lepším obrazem

Jak nahradit webkameru: jde to telefonem, zadarmo a s lepším obrazem

** Koronavirus donutil mnohé zaměstnance pracovat z domova ** V souvislosti s tím vzrostla poptávka po webových kamerách ** Webkameru ale nemusíte kupovat – stačí mobil a aplikace!

Karel Kilián | 13

Šest nejlepších služeb a aplikací pro automatizaci online světa a chytré domácnosti

Šest nejlepších služeb a aplikací pro automatizaci online světa a chytré domácnosti

** Nastavte si automatiku na každodenní rutinní záležitosti ** Propojte online služby a chytrou domácnost ** Vybrali jsme šest nejlepších služeb pro automatizaci

Karel Kilián | 14

Velká datová loupež. Proč mají disky nižší kapacitu, než uvádějí?

Velká datová loupež. Proč mají disky nižší kapacitu, než uvádějí?

** Na disk nikdy neuložíte tolik dat, jak tvrdí výrobce ** Ajťáci si vymysleli vlastní jednotky jako mebibajt ** Zmatky vznikají i kvůli různým výjimkám

Lukáš Václavík | 100

Teachable Machine: Umělá inteligence za pět minut i bez doktorátu z ČVUT

Teachable Machine: Umělá inteligence za pět minut i bez doktorátu z ČVUT

** Pochopit techniky a principy A.I. je složité ** Ale nebojte, jde to i bez doktorátu z IT a matematiky ** Vyzkoušíme generátor neuronových sítí od Googlu

Jakub Čížek | 9

Podívejte se na Windows z roku 1990. Před 30 lety přišly Windows 3.0 a líbily se nám

Podívejte se na Windows z roku 1990. Před 30 lety přišly Windows 3.0 a líbily se nám

** 22. května 1990 uvedl Microsoft Windows 3.0 ** Systém z Microsoftu definitivně udělal lídra na desktopu ** Tehdejší Windows byly vlastně grafickou nadstavbou nad MS-DOS

Jakub Čížek | 74


Aktuální číslo časopisu Computer

Megatest 24 PC zdrojů

Jak využít umělou inteligenci

10 špičkových sluchátek s ANC

Playstation 5 vs Xbox Series X