» Poradna » Programy

Excel, vynulování součtu po překročení zadané hodnoty

 |   |  Microsoft Windows 7 Firefox 45.0

Ve sloupci Excel tabulky generuji pomocí funkce =RANDBETWEEN(15;60) náhodná čísla (čas v minutách) v rozsahu 15-60 minut, která pak v dalším sloupci (od začátku) sčítám. Pokud součet překročí hodnotu 474 minut, potřebuji nějak vynulovat součet a začít od nuly. Tabulku vytvářím tahem prvního řádku dolů. Jak to udělat ?

Odpovědi na otázku

 |   |  Microsoft Windows 8.1 IE 11.0

=KDYŽ(B1+A2<474;B1+A2;0)BTW: k čemu je to dobré?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

pokud tam nemá být ta 0, tak=KDYŽ(B1+A2<474;B1+A2;A2)48 4846 9415 10921 13039 16923 19255 24717 26419 28325 30860 36822 39057 44725 47257 5732 8921 11059 16927 19658 25423 27739 31655 37125 39628 42426 45053 5332 85

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 45.0

Díky, nějak jsem to ale nepochopil. Když dám ten vzorec do sloupce B, tak mi to hlásí cyklický odkaz. Ve sloupci A mám náhodně generovaná čísla, ve sloupci B vzorec např. v řádku 7 =SUMA($A$1:A7)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

v A1 nahodne číslov B1 =A1v A2 nahodne číslov B2 ten vzorec(pricita se nahodne číslo k poslednímu sečtenému, není potřeba porad scitat všechno)radek 2 zkopirujes (stahnes) na libovolny počet radkuJakou skolu navstevujes?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Linux Chrome 49.0.2623.112

Domácí úkol.PrasatkoPee

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Co je v té škole učí?

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Překročení


Určitě si přečtěte

Nejlepší příslušenství k počítači. Tipy na osvědčené klávesnice, tiskárny, routery…

Nejlepší příslušenství k počítači. Tipy na osvědčené klávesnice, tiskárny, routery…

** Tipy na klávesnice, myši, routery, tiskárny, sluchátka a další věci k počítačům ** Poradíme, s jakými produkty neuděláte chybu ** Vybíráme jak příslušenství na běžnou práci, tak na hraní her

David Polesný | 20

Google Coral: Raspberry Pi s čipem, který zpracuje 4 biliony operací za sekundu

Google Coral: Raspberry Pi s čipem, který zpracuje 4 biliony operací za sekundu

** Je to velké jako Raspberry Pi ** Ale je to až o několik řádů rychlejší ** Dorazil nám exotický Google Coral s akcelerátorem Edge TPU

Jakub Čížek | 18

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

** Strojové učení ještě nepřitáhlo takový zájem jako na začátku prázdnin ** Ne, umělá inteligence nenašla lék na rakovinu ** Naučila se svlékat ženy nejen z plavek

Jakub Čížek | 35

Vyzkoušeli jsme chytrou čínskou zásuvku Sonoff S26 za tři stovky. Nevyhořeli jsme

Vyzkoušeli jsme chytrou čínskou zásuvku Sonoff S26 za tři stovky. Nevyhořeli jsme

** Je sice z Aliexpressu, ale funguje ** Můžete ji ovládat hlasem přes Amazon Echo nebo Google Home ** Za tři stovky zautomatizuje menší 230V spotřebič

Jakub Čížek | 109


Aktuální číslo časopisu Computer

Megatest: 20 powerbank s USB-C

Test: mobily do 3 500 Kč

Radíme s výběrem routeru

Tipy na nejlepší vánoční dárky