» Poradna » Programy

Excel tabulka a vzorce (hodnoty a násobení)

 |   |  Microsoft Windows 10 Chrome 68.0.3440.106

Neví někdo elegantní řešení, jak udělat součet buněk s tím, že se každá buňka vynásobí s hodnotou pod ní? Vím, že je to blbě popsáno, dám příklad.Př.: Chci hodnotu, která se rovná: A1 - A5 (hodnoty třeba 2; 3; 5; 1; 2;) s tím, že se každá z těchto buněk vynásobí s hodnotou pod ní (aka hodnoty B1 - B5 budou znovu 2; 3; 5; 1; 2;) a výsledek, jenž mi to vyhodí by měl být 2*2+3*3+5*5+1*1+2*2 --> 33.Momentální řešení je složité pouze délkou( =A1*B1+A2*B2+A3*B3...) a tak dále.Jen se ptám, jestli existuje "elegantnější řešení tohoto problému.Děkuji

Odpovědi na otázku

 |   |  Android AppleMAC-Safari 5.0

Nevím sice co jsou aka hodnoty, ale třeba se naučit pracovat s funkcemi Excelu?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Chrome 68.0.3440.106

=SOUČIN.SKALÁRNÍ(A1:A5;B1:B5)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP AppleMAC-Safari 5.0

Přečti si to po sobě znovu. 'se každá z těchto buněk vynásobí s hodnotou pod ní'. Pod A1 je A2. V řešení (mimochodem chybném) ale násobíš A1 * B1.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Elegantní řešení


Určitě si přečtěte

Biblická potopa Česka: Jak bychom dopadli, kdyby nás zatopil oceán

Biblická potopa Česka: Jak bychom dopadli, kdyby nás zatopil oceán

** Představte si biblickou potopu ** Nejprve zaniknou Děčín a Břeclav, pak i Brno a Praha ** Hlavním městem se stane Jihlava a zbytky Čechů přežijí na Kvildě

Jakub Čížek | 93

Nejlepší notebooky do 10 000 korun: Co koupit a čemu se raději vyhnout

Nejlepší notebooky do 10 000 korun: Co koupit a čemu se raději vyhnout

** Do deseti tisíc korun lze dnes koupit slušné notebooky ** V nabídce ale i tak převládají zastaralé a pomalé modely ** Poradíme, jak dobře vybrat i s omezeným rozpočtem

David Polesný | 103

13 praktických tipů a triků pro Mapy.cz, které možná neznáte

13 praktických tipů a triků pro Mapy.cz, které možná neznáte

** Mapy.cz neslouží jen k zobrazení podkladů a plánování tras ** Nabízejí celou řadu dalších praktických funkcí a možností ** Vybrali jsme třináct tipů a triků, o kterých možná nevíte

Karel Kilián | 36

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

** Strojové učení ještě nepřitáhlo takový zájem jako na začátku prázdnin ** Ne, umělá inteligence nenašla lék na rakovinu ** Naučila se svlékat ženy nejen z plavek

Jakub Čížek | 35

10 mýtů a polopravd o bateriích, kterým možná ještě věříte

10 mýtů a polopravd o bateriích, kterým možná ještě věříte

** Kolem baterií a akumulátorů koluje řada mýtů, nepravd a polopravd ** Dnes vám devět z nich zkusíme vyvrátit na základě faktů ** Většina z nich totiž neplatí pro moderní lithiové baterie

Karel Kilián, David Polesný | 99


Aktuální číslo časopisu Computer

Megatest: 20 powerbank s USB-C

Test: mobily do 3 500 Kč

Radíme s výběrem routeru

Tipy na nejlepší vánoční dárky