» Poradna » Programy

Excel-pomoc s propojením dvou sloupců

 |   |   |  [194.108.140.---]

Potřeboval bych poradit.Mám takový problém v Excelu.Ale nevím jak to přesně formulovat.
Tak se o to aspoň pokusím:

Mám ceník určitých produktů v Excelu.

V jednom sloupci jsou naše výrobní ,dodavatelská čísla.
Ve sloupci vedle jsou čísla odběratelů.S těmi oni pracují.Mají to tak zalistované.

No a já bych potřeboval je nějak vzájemně propojit.

Aby když mi od nich přijde tabulka,kde jsou uvedeny pouze ty jejich numera nějak automaticky přiřadil čísla naše.
Prý to nějak jde.

Snad jsem ten můj problém pochopitelně vysvětlil.
Budu moc vděčný za každou radu.

Odpovědi na otázku

 |   |   |  [193.165.169.---]

No ja bych to propojeni v Excelu nedelal, protoze to neumim, ale zkusil bych to v nejake databaze. Prevedl bych dodany Excelovy soubor do databazoveho formatu a pres qery - dotaz a propojil se svou databazi svych dodavatelskych cisel, vyrobnich cisel a odberatelskych cisel do relace s odberatelskymi cisly toho co dostanu od svych partneru. Ja bych to delal bud v MS Access nebo ve FoxPro nebo v Dbase.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |   |  [80.188.190.---]

Accessa, ale pokud to musi byt vylozene v excelu, tak na toto se pouziva funkce SVYHLEDAT..

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   | 

Jj, potrebuješ len prevodnú tabuľku, kde v prvom stlpci budu "jejich numera" a v druhom "vaše". Túto tabuľku potom bude využívať na získanie vašeho čísla tam, kde máš ich čísla.
Použiješ ten príkaz spomenutý - SVYHLEDAT (resp. nazov príkazu podla jazyka, v ktorom máš excel) asi takto: SVYHLEDAT(Param1; Tab; Param2).
Pričom:
Param1 je hodnota, ku ktorej hľadáš ekvivalent (t.j. jejich hodnota),
Tab je tabuľka (2 stĺpce, x riadkov) vktorej sú v riadkoch príslušné ekvivalenty, jejich hodnoty sú v prvom stĺpci!
Param2 je číslo stĺpca z tabuľky (Tab), z ktorého sa bude brať ekvivalent (t.j. vaše hodnoty). Z tohto vyplýva aj možnosť, že nemusíš mať tú tabuľku (Tab) iba dvojrozmernú, že to môže byť prevzaté aj s väčšej tabuľky a zvolíš si stĺpce, ale tak je tá prevodná tabuľka konštantná,tak je dobre hu mať niekde extra (v samostatnom súbore, alebo aspoň na samostatnom liste).
 
Príklad: "=SVYHLEDAT(A6;List1!$A$1:$B$10;2)"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |   |  [195.146.149.---]

=IF(A:A=12345;54321;IF(A:A=123456;654321))
na zaklade podobneho vzorca len si ho rozpis na vsetky cisla ako ich potrebujes nahradit a veci ktore pridu nove ti budu oznacene hodnotou FALSE takze sa nestane ze na nieco zabudnes, popripade napisat cez makro.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |   |  [194.108.140.---]

Díky moc za rady.Jdu to zkoušet.Snad to nějak rozjedu.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Andy, Ceník



Určitě si přečtěte


Aktuální číslo časopisu Computer

Test 6 odolných telefonů a 22 powerbank

Srovnání technologií QLED a OLED

Měřte své sportovní výkony

Sady pro chytrou domácnost