» Poradna » Programy

Excel: #NENÍ_K_DISPOZICI

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 5/5
 |   |  Microsoft Windows XP Firefox 19.0  |  [178.255.168.---]

Když vybírám z menu položky, tak se ve vedlejší buňce zobrazí správně hodnota, díky funkci SVYHLEDAT. Ale když nevyberu položku z menu a napíšu do buňky vlastní text (E39), tak se zobrazí #NENÍ_K_DISPOZICI (F39). Chtěl bych, aby se tam po napsání položky mimo vysouvacího menu zobrazila prázdná buňka. Příklad je možné stáhnout na tomto odkazu: http://db.tt/vMCxugoiDíky za rady

Odpovědi na otázku

avatar
CN Invest |  | Microsoft Windows 7 Chrome 25.0.1364.172

Musíte do vzorce přidat testování na chybovou hodnotu. Takže vzorec pro F39 bude vypadat třeba takto:=KDYŽ(E39="";"";KDYŽ(JE.NEDEF(SVYHLEDAT(E39;Ceník!$A$1:$B$31;2;0));"";SVYHLEDAT(E39;Ceník!$A$1:$B$31;2;0)))EDIT: Vidím, že se tady nezlomí řádek, tak dvakrát klikněte na vzorec a zkopírujte ho do Excelu.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Firefox 19.0  |  [178.255.168.---]

Funguje. To jsem přesně potřeboval. Díky!!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 51.0.2704.103  |  [213.195.214.---]

Díky za pomoc!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 19.0  |  [178.255.168.---]

Nebo takto:=IFERROR(KDYŽ(E39="";"";SVYHLEDAT(E39;Ceník!$A$1:$B$31;2;0));"")

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP Firefox 19.0  |  [178.255.168.---]

Nefunguje, ale i tak díky

Souhlasím  |  Nesouhlasím  |  Odpovědět



Určitě si přečtěte


Jak fungují kryptoměny: Za oponou se odehrává perfektně organizovaný chaos

Jak fungují kryptoměny: Za oponou se odehrává perfektně organizovaný chaos

** Bitcoin letos trhal rekordy ** Zdaleka není sám, jsou tu i další kryptoměny ** Jak vlastně kyberpeníze v nitru fungují?

13.  12.  2017 | Jakub Čížek | 48

Pojďme programovat elektroniku: Vyzkoušíme linuxový počítač Omega2 za stokorunu

Pojďme programovat elektroniku: Vyzkoušíme linuxový počítač Omega2 za stokorunu

** Má velikost poštovní známky ** Stojí něco málo přes stovku ** A tvrdí o sobě, že je to nejmenší linuxový počítač

10.  12.  2017 | Jakub Čížek | 7