» Poradna » Programy

EXCEL Chyba funkce " SVYHLEDAT"

avatar
 | Microsoft Windows 8.1 Chrome 37.0.2062.124

Ahoj.Mám tabulku s cca 60 řádky. V tabulce se má vyhledat číslo práce podle druhu práce. Údaje se vyhledávají v tabulce kde mám v levém sloupci názvy a v pravém čísla.Je použit vzorec =KDYŽ(A6=0;0;SVYHLEDAT(A6;Legenda!A$5:F$80;2)). Vše funkuje takřka dobře až na to že údaje z posledních několika řádků se vyjadřují chybně ( je použito číslo z jiného řádku. Je pravdou že některé názvy jsou si podobné. Např.( prémie odvoz, postřik prémie) a podobně, Myslel jsem že funkce vyhledává z celého řetězce. Je možná chyba v té podobnosti nebo je možná chyba někde jinde.Předem děkuji za vaší radu.

Odpovědi na otázku

 |   |  Microsoft Windows 7 Chrome 37.0.2062.124

Nemam tu Excel, ale takto to nefunguje?=KDYŽ(A6=0;0;SVYHLEDAT(A6;Legenda!$A$5:$F$80;2;0))

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 37.0.2062.124

Teda vlastne takto:=KDYŽ(A6=0;0;SVYHLEDAT(A6;Legenda!$A$5:$F$80;2;NEPRAVDA))

Souhlasím  |  Nesouhlasím  |  Odpovědět
avatar
 | Microsoft Windows 8.1 Chrome 37.0.2062.124

Díky moc. Funguje.

Souhlasím  |  Nesouhlasím  |  Odpovědět
avatar
 | Microsoft Windows 7 Firefox 35.0

ta čeština je úchylná

Souhlasím  |  Nesouhlasím  |  Odpovědět
avatar
 | Microsoft Windows 8.1 Chrome 37.0.2062.124

Děkuji za tento podnětný příspěvek.JA NELOZUMIM CESKYNení kontrola gramatiky v PC poradně tak trochu úchylka?Víc mě zajímala chyba ve vzorečku a s tou mi již pomohly.Díky.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Forever, Prémie, Postřik, Legenda


Určitě si přečtěte

Podívejte se na Windows z roku 1990. Před 30 lety přišly Windows 3.0 a líbily se nám

Podívejte se na Windows z roku 1990. Před 30 lety přišly Windows 3.0 a líbily se nám

** 22. května 1990 uvedl Microsoft Windows 3.0 ** Systém z Microsoftu definitivně udělal lídra na desktopu ** Tehdejší Windows byly vlastně grafickou nadstavbou nad MS-DOS

Jakub Čížek | 75

WindowsFX: Nainstalujte to mamce a taťkovi. Ani nepoznají, že to je Linux

WindowsFX: Nainstalujte to mamce a taťkovi. Ani nepoznají, že to je Linux

** Po dvou měsících tu máme další linuxovou kopii ** Tentokrát jde o imitaci Desítek ** Sestavili ji brazilští geekové nad Ubuntu

Jakub Čížek | 135

Je lepší hrát na PC, či na konzolích? Nebo jsou i jiné možnosti?

Je lepší hrát na PC, či na konzolích? Nebo jsou i jiné možnosti?

** Jaké jsou výhody a nevýhody hraní na počítači? ** Co mají společného a v čem se liší Xbox One, PS4 a Switch? ** Na čem hrát, když nemáte výkonné PC ani konzoli?

Lukáš Václavík | 123

Windy je laboratoř na počasí: 12 tipů, jak se ve službě vyznat a využít ji naplno

Windy je laboratoř na počasí: 12 tipů, jak se ve službě vyznat a využít ji naplno

** Předpověď počasí Windy nabízí nepřebernou škálu funkcí ** Zorientovat se v nich nemusí být vždy snadné ** Proto přinášíme 12 užitečných tipů a triků

Karel Kilián | 10

Jak odposlouchávat sousedy: Bizarní Lamphone a další netušené techniky

Jak odposlouchávat sousedy: Bizarní Lamphone a další netušené techniky

** Lamphone je další bizarní technika odposlechu ** Zneužívá obyčejnou stropní lampu ** Podívejte se na další bizarní experimenty

Jakub Čížek | 17

Zapomeňte na kometu, české nebe každý den křižují mnohem zajímavější kousky

Zapomeňte na kometu, české nebe každý den křižují mnohem zajímavější kousky

** České nebe každý den křižuje hromada exotických letounů ** Na populární mapě Flightradar24 je ale nenajdete ** Jsou to vojenské letouny USA, UK a NATO

Jakub Čížek | 37


Aktuální číslo časopisu Computer

Megatest: nejlepší notebooky do 20 000 Kč

Test 8 levných IP kamer

Jak vybrat bezdrátová sluchátka

Testujeme Android 11