» Poradna » Programy

Excel 2003 funkce COUNTIF v závislosti na více podmínkách

 |   |  Microsoft Windows XP Firefox 28.0

Zdravím,nevíte někdo jak vyřešit následující problém?současnost: na každý měsíc mám novou tabulku, používám funkci COUNTIF pro sečtení prodaných výrobků za pracovníky, zde COUNTIF postačuje, jelikož mám tabulku časově omezenou jedním měsícem a proměnné jsou výrobek a pracovníkbudoucnost:tabulka časově neomezená, tj. už není 1 tabulka 1 měsíc,jak zajistit součet v závisloti za jednotlivé měsíce? Tady už mi funkce COUNTIF nestačí, protože proměnné jsou výrobek, pracovník a časové období po jednotlivých měsících děkuji za nakopnutíGJFish

Mohlo by vás také zajímat

Odpovědi na otázku

 |   |  Microsoft Windows 7 Firefox 27.0

Rozšiř podmínku.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Kdyby jsi měl Excel novější než 2003, pak by ti jednoduše stačila funkce COUNTIFS.Ale jinak můžeš snad ve všech verzích aplikovat funkci SOUČIN.SKALÁRNÍ (SUMPRODUCT).Příklad zde:http://codesnip.net/countifs-and-sumifs-in-ex...

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP IE 8.0

Nebo použij maticový vzorec, který ti nahradí funkci COUNTIFS:=SUMA(((A1:A24)=1)*((B1:B24)="a")) - CTRL+SHIFT+ENTER- vzorec sečte všechny buňky, které obsahují v oblasti A1:A24 hodnotu 1 a zároveň v oblasti B1:B24 obsahují písmeno "a"

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Měsíc, Budoucnost, Pracovník, Výrobek, Časové období, Současnost, Období



Nejlepší herní notebooky i pracovní stroje pod stromeček. Nemusíte platit ranec, abyste si užili kvalitu

Nejlepší herní notebooky i pracovní stroje pod stromeček. Nemusíte platit ranec, abyste si užili kvalitu

Výborné notebooky najdete už kousek nad hranicí 20 tisíc, přičemž dražší stroje nabídnou nejen vyšší výkon, ale i lepší provedení. Hlavně si už můžete vybírat notebook přímo na míru konkrétním požadavkům.

Tomáš Holčík
Notebooky
Recenze mobilní hry Slovní Duel. Nadějný, ale nedotažený fotbálek

Recenze mobilní hry Slovní Duel. Nadějný, ale nedotažený fotbálek

Procvičujete rádi slovní zásobu a chcete zapálit mozkové závity? Třeba bude tahle hříčka z českých luhů a hájů zrovna pro vás!

Ladislav Novák
Mobilní hryRecenze
Programujeme ZX Spectrum: Ten nejhloupější možný program v Basicu
Jakub Čížek
Pojďme programovat elektronikuHistorieProgramování
Recenze Windows 11. Microsoft nás opíjí rohlíkem a omezuje použitelnost

Recenze Windows 11. Microsoft nás opíjí rohlíkem a omezuje použitelnost

** Oproti Desítkám významně stouply hardwarové požadavky ** Windows 11 mají nový vzhled, ale výrazně narušují workflow. ** Potěší vyhledávání, multitasking i rychlejší aktualizace

Petr Urban
Windows 11Testy
Nová volitelná aktualizace systému Windows 10 opravuje 38 problémů
Karel Kilián
Windows UpdateAktualizaceWindows 10

Aktuální číslo časopisu Computer

Megatest bezdrátových sluchátek

Test dvoudiskových NASů

Průvodce nákupem základní desky