» Poradna » Programy

Excel 2003 funkce COUNTIF v závislosti na více podmínkách

 |   |  Microsoft Windows XP Firefox 28.0

Zdravím,nevíte někdo jak vyřešit následující problém?současnost: na každý měsíc mám novou tabulku, používám funkci COUNTIF pro sečtení prodaných výrobků za pracovníky, zde COUNTIF postačuje, jelikož mám tabulku časově omezenou jedním měsícem a proměnné jsou výrobek a pracovníkbudoucnost:tabulka časově neomezená, tj. už není 1 tabulka 1 měsíc,jak zajistit součet v závisloti za jednotlivé měsíce? Tady už mi funkce COUNTIF nestačí, protože proměnné jsou výrobek, pracovník a časové období po jednotlivých měsících děkuji za nakopnutíGJFish

Mohlo by vás také zajímat

Odpovědi na otázku

 |   |  Microsoft Windows 7 Firefox 27.0

Rozšiř podmínku.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Kdyby jsi měl Excel novější než 2003, pak by ti jednoduše stačila funkce COUNTIFS.Ale jinak můžeš snad ve všech verzích aplikovat funkci SOUČIN.SKALÁRNÍ (SUMPRODUCT).Příklad zde:http://codesnip.net/countifs-and-sumifs-in-ex...

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows XP IE 8.0

Nebo použij maticový vzorec, který ti nahradí funkci COUNTIFS:=SUMA(((A1:A24)=1)*((B1:B24)="a")) - CTRL+SHIFT+ENTER- vzorec sečte všechny buňky, které obsahují v oblasti A1:A24 hodnotu 1 a zároveň v oblasti B1:B24 obsahují písmeno "a"

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Měsíc, Budoucnost, Pracovník, Výrobek, Časové období, Současnost, Období