» Poradna » Programy

Excel - zapsání matematické operace z buňky

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 5/5
 |   |  Microsoft Windows 7 Chrome 61.0.3163.100

Dobrý den, chtěl bych se zeptat, zdali jde při psaní do řádku vzorců vzít matematická operace z buňky tak, abych ji nemusel vepisovat ručně.Příklad: Mám buňky s hodnotami: A1 = "5", A2 = "+", A3 = "2".V řádku vzorců bych chtěl zadat "=A1A2A3" a vypsalo by mi to "7". Existuje tu tato možnost? Díky.

Odpovědi na otázku

 |   |  Microsoft Windows XP AppleMAC-Safari 5.0  |  [89.177.187.---]

=A1A2A3 určitě ne. Ale dá se vymyslet i mnohem pomalejší a složitější způsob.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Bez makra NE a i tam bych se toho bál, pokud se rozsah buněk bude měnit

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 56.0  |  [217.64.9.---]

S rozsahem buněk není problém, můžeš je předat jako parametr.Pro tazatele:Pokud budeš mít vždy jen dvě buňky s hodnotami a 4 základní operace (+, -, *, /), můžeš to vyřešit pomocí vnořených funkcí KDYŽ:=KDYŽ(A2="+"; A1+A3; KDYŽ(A2="-";A1-A3; KDYŽ(A2="*";A1*A3; A1/A3)))

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 7 Chrome 61.0.3163.100

Mockrát děkuji za pomoc - mám to jen pro jedno cvičení a takto mi to stačí.Hezký den!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 55.0  |  [65.197.242.---]

Související témata: Operace



Určitě si přečtěte


Velká podzimní aktualizace Windows 10 je tady: Co přináší Fall Creators Update

Velká podzimní aktualizace Windows 10 je tady: Co přináší Fall Creators Update

** Po půl roce je tu další aktualizace Windows ** A opět přináší hlavně hromadu drobných kosmetických vylepšení ** Podívali jsme se na ty nejzajímavější

Včera | Jakub Čížek | 108

Budoucností Windows 10 je Fluent Design. Takto bude jednou vypadat celý systém

Budoucností Windows 10 je Fluent Design. Takto bude jednou vypadat celý systém

** Fluent Design je vzhled, do kterého postupně Microsoft převleče celý systém ** Staví na průhlednosti a velkých plochách ** Do Windows 10 se z části dostane už zítra při vydání podzimní aktualizace

16.  10.  2017 | Stanislav Janů | 148


Aktuální číslo časopisu Computer

Nový seriál o programování elektroniky

Otestovali jsme 17 bezdrátových sluchátek

Jak na nákup vánočních dárků ze zahraničí

4 tankové tiskárny v přímém souboji