» Poradna » Programy

Excel - zapsání matematické operace z buňky

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 6/6
 |   |  Microsoft Windows 7 Chrome 61.0.3163.100  |  [94.125.216.---]

Dobrý den, chtěl bych se zeptat, zdali jde při psaní do řádku vzorců vzít matematická operace z buňky tak, abych ji nemusel vepisovat ručně.Příklad: Mám buňky s hodnotami: A1 = "5", A2 = "+", A3 = "2".V řádku vzorců bych chtěl zadat "=A1A2A3" a vypsalo by mi to "7". Existuje tu tato možnost? Díky.

Odpovědi na otázku

 |   |  Microsoft Windows XP AppleMAC-Safari 5.0  |  [89.177.187.---]

=A1A2A3 určitě ne. Ale dá se vymyslet i mnohem pomalejší a složitější způsob.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 IE 11.0

Bez makra NE a i tam bych se toho bál, pokud se rozsah buněk bude měnit

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 10 Firefox 56.0  |  [217.64.9.---]

S rozsahem buněk není problém, můžeš je předat jako parametr.Pro tazatele:Pokud budeš mít vždy jen dvě buňky s hodnotami a 4 základní operace (+, -, *, /), můžeš to vyřešit pomocí vnořených funkcí KDYŽ:=KDYŽ(A2="+"; A1+A3; KDYŽ(A2="-";A1-A3; KDYŽ(A2="*";A1*A3; A1/A3)))

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 7 Chrome 61.0.3163.100

Mockrát děkuji za pomoc - mám to jen pro jedno cvičení a takto mi to stačí.Hezký den!

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 55.0  |  [65.197.242.---]
 |   |  Microsoft Windows 10 Chrome 62.0.3202.75

Nejspíš by to šlo i trochu jinak. Přirozený zápis lze řešit (drobátko komplikovaně) i s funkcí TABULKA.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Operace



Určitě si přečtěte


Pojďme programovat elektroniku: Vyzkoušíme linuxový počítač Omega2 za stokorunu

Pojďme programovat elektroniku: Vyzkoušíme linuxový počítač Omega2 za stokorunu

** Má velikost poštovní známky ** Stojí něco málo přes stovku ** A tvrdí o sobě, že je to nejmenší linuxový počítač

10.  12.  2017 | Jakub Čížek | 7

Jak fungují kryptoměny: Za oponou se odehrává perfektně organizovaný chaos

Jak fungují kryptoměny: Za oponou se odehrává perfektně organizovaný chaos

** Bitcoin letos trhal rekordy ** Zdaleka není sám, jsou tu i další kryptoměny ** Jak vlastně kyberpeníze v nitru fungují?

Včera | Jakub Čížek | 47