» Poradna » Programy

Excel - sofistikovaná KDYŽ funkce?

 |   |  Microsoft Windows 10 Firefox 58.0

Dobrý den, potřeboval bych poradit s vytvořením vzorce pro následující problém:Mám sérii souřadnic X (sloupec B), Y (sloupec C) rozdělených do 4 sektorů po šesti (B,C 2-7; B,C 8-13; B,C 14-19; B,C 20-25) (viz obr. níže). Získám výsledek nějakých souřadnic a zapíšu jej do sloupce D2 a E2. Pokud se obě souřadnice shodují se souřadnicemi ve sloupci B a C, získám výsledek v závislosti na sektoru. Tedy pokud souřadnice D2 a E2 odpovídají např. souřadnicím B2 a C2, výsledek bude 1. Pokud souřadnice D2 a E2 odpovídají např. souřadnicím B8 a C8, výsledek bude 2, atp. Vytvořil jsem pro to funkci KDYŽ A NEBO, která by šla manuálně naklikat pro nevelké množství souřadnic. Ale když bych měl těch souřadnic 500, asi bych se zbláznil. Mohl by mi někdo poradit, jak si práci zjednodušit? Mockrát děkuji, platím zlatem!Popis problému: http://tinypic.com/r/sz7jvk/9

Odpovědi na otázku

 |   |  Microsoft Windows 10 Firefox 58.0

Já bych to provedl následovně:1. Vytvořil bych pomocný sloupec (např. H), do něhož bych složil oba kódy z B a C tímto stylem:H2: = B2 & " " & C22. Do vedlejšího pomocného sloupce (I) bych napsal odpovídající čísla sektorů (tj. I2:I7=1, I8:I13=2, atd.)3. Pro výsledek ve sloupci F bych pak použil funkci SVYHLEDAT:F2: = SVYHLEDAT(D2&" "&E2; H:I; 2; 0)

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Souřadnice, Výsledek


Určitě si přečtěte

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

Jak funguje kontroverzní program, který ženám krade plavky. Mají se čeho bát?

** Strojové učení ještě nepřitáhlo takový zájem jako na začátku prázdnin ** Ne, umělá inteligence nenašla lék na rakovinu ** Naučila se svlékat ženy nejen z plavek

Jakub Čížek | 35

Dnes nastal konec Windows 7. Ale nepropadejte panice, počítač vám nastartuje i zítra

Dnes nastal konec Windows 7. Ale nepropadejte panice, počítač vám nastartuje i zítra

** Dnes končí podpora Windows 7 a systém formálně umírá ** Co to ale znamená v praxi a bude mi PC fungovat i zítra? ** A mohu i v lednu 2020 zdarma přejít na Windows 10?

Jakub Čížek | 121

Vybrali jsme 21 programovatelných hraček a stavebnic pro děti i jejich rodiče

Vybrali jsme 21 programovatelných hraček a stavebnic pro děti i jejich rodiče

** Získejte děti pro matematiku a základy techniky ** Kupte jim hračku nebo stavebnici, které vdechnou vlastní život ** Vybrali jsme 21 stavebnic pro malé caparty i budoucí experty na A.I.

Jakub Čížek | 11



Aktuální číslo časopisu Computer

Test 9 bezdrátových reproduktorů

Jak ovládnout Instagram

Test levných 27" herních monitorů

Jak se zbavit nepotřebných věcí na internetu