» Poradna » Programy

Excel - podmínka a akce pro funkci "když" uložené v jiné buňce

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 3/3
 |   |  Microsoft Windows 10 Chrome 61.0.3163.100

Dobrý den,chtěl bych se zeptat, jestli je možné odkazovat v excelu na buňku s podmínkou a popř. i akcí.Př.: v buňce A1 bude napsáno "B1>1" a v buňce A2 bude "B2+B3". Teď bych chtěl kamkoliv napsat - když bude platit podmínka v buňce A1 tak napiš A2 (hodnotu, ne vzorec).Existuje něco takového?

Odpovědi na otázku

avatar
 | Microsoft Windows 10 Chrome 61.0.3163.100

Dobrý den, řešení je, trochu složité, ale vyzkoušel jsem to a je funkční, i bez programování. Jedná se o využití skryté funkce VYHODNOTIT, angl. EVALUATE. Ta funguje ale jen dle postupu:1) mějme buňky A1 a A2, jak jste uvedel. Do buněk B1 až B3 jsem vyplnil testovací čísla 10,20,302) Do buňky C1 si kliknu a přejdu na kartu Vzorce (Formulas), Definovat název (Define name). Vyplním název třeba "eval", do políčka Odkaz na napíšu =VYHODNOTIT, angl. EVALUATE, takže třeba =VYHODNOTIT($A1) a potvrdím OK.3) Do buňky C1 následně napíšu vzorec =eval ,mohu jej roztáhnout dolů na ostatní řádky, abych takto převedl všechny výrazy ve sloupci A na výpočty.4) S těmito "výpočty" ve sloupci C pak následně pracuji ve funkci KDYŽ v dalším sloupci, takže třeba do D1 ... =KDYŽ(C1=PRAVDA;C2;něco pro nepravdu)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 | Microsoft Windows 10 Chrome 61.0.3163.100

Děkuji moc, funguje dle očekávání. O funkci "definované názvy" jsem dokonce nikdy neslyšel, takže jsem se i něco přiučil. Také mě napadlo vytvořit si vlastní funkci, ale do toho se mi úplně nechtělo.Ještě bych měl dotaz k té druhé části - potřeboval bych dosadit do té funkce (když) vzoreček (v tom příkladu jsem měl "B2+B3") - a k tomu jej ještě dosadit podle toho, ve kterém řádku se nachází (relaticvní odkaz). Tzn. když ta funkce bude v řádku 2, tak tam bude např. B2+B3; když v řádku 3 tak B3+B4 atd.Je to nějak možné, popř. přes vlastní funkci?

Souhlasím  |  Nesouhlasím  |  Odpovědět
avatar
 | Microsoft Windows 10 Chrome 61.0.3163.100

Stačí funkci rozkopírovat dolů, ale u té první buňky, tedy v našem příkladu C1 dát dolary. =KDYŽ($C$1=PRAVDA;C2;něco pro nepravdu).

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Podmínka, Akce



Určitě si přečtěte


Velká podzimní aktualizace Windows 10 je tady: Co přináší Fall Creators Update

Velká podzimní aktualizace Windows 10 je tady: Co přináší Fall Creators Update

** Po půl roce je tu další aktualizace Windows ** A opět přináší hlavně hromadu drobných kosmetických vylepšení ** Podívali jsme se na ty nejzajímavější

Včera | Jakub Čížek | 106

Budoucností Windows 10 je Fluent Design. Takto bude jednou vypadat celý systém

Budoucností Windows 10 je Fluent Design. Takto bude jednou vypadat celý systém

** Fluent Design je vzhled, do kterého postupně Microsoft převleče celý systém ** Staví na průhlednosti a velkých plochách ** Do Windows 10 se z části dostane už zítra při vydání podzimní aktualizace

16.  10.  2017 | Stanislav Janů | 146


Aktuální číslo časopisu Computer

Nový seriál o programování elektroniky

Otestovali jsme 17 bezdrátových sluchátek

Jak na nákup vánočních dárků ze zahraničí

4 tankové tiskárny v přímém souboji