» Poradna » Programy

Excel - KDYŽ(A(SVYHLEDAT.. kolize

 |   |  Microsoft Windows 8.1 IE 11.0

Dobrý den,chtěl bych Vás moc poprosit o radu, kdy nevím, kde mám chybu ve vzorci.Pro názornost problému přikládám odkaz na obrázek, který plně vystihuje můj problém.http://uloz.to/x9wFsHZu/excelhelp-pngS díky a pozdravemJV

Odpovědi na otázku

 |   |  Microsoft Windows 8.1 IE 11.0

Chyba je zřejmá Funkce SVYHLEDAT hledá v prvním sloupci. V tebou vyznačené oblasti $F:$H se v prvním sloupci "ČR" nenachází, takže ti vzorec vrací chybu. Buď uprav oblast na $G:$H, nebo použij funkci INDEX.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

První SVYHLEDAT hledá v 1.sloupci a nachází správnou odpověď: NEPRAVDA.Problém je u druhého SVYHLEDAT, které má hledat ČR (tedy ve 2.sloupci vybrané oblasti). Bohužel zde dochází ke kolizi. Jak kdyby logická funkce A nechtěla vzít podruhé funkci SVYHLEDAT.Při Vaší radě jsem změnil oblast vyhledávání u druhého SVYHLEDAT (z $F:$H na $G:$H) a zadal hledat parametr ČR v 1.sloupci. Výsledkem bylo prázdné políčko.Cílem má být hodnota 15.Jak prosím postupovat?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Abych ještě upřesnil zadání: Mám porovnat dva parametry (OVOCE a ZEMĚ) a při shodě obou parametrů přiřadit správnou částku.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

pozn.: kdybych nechal Vaši verzi (záměna vyhledávané oblasti u druhého SVYHLEDAT), koliduje už jen podmínka KDYŽ při shodě (tedy při [ANO] = H2).Jak, prosím, nadefinovat [ANO], abych dostal správnou částku?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Nyní mám tedy tuto funkci: =KDYŽ(A(SVYHLEDAT(A2;$F:$H;1;NEPRAVDA)=NEPRAVDA;SVYHLEDAT(B2;$G:$H;1;NEPRAVDA)=NEPRAVDA);H2;"nic")a potřebuji nadefinovat podmínku [ANO] u funkce KDYŽ (doteď rovnu H2), aby vrátila hodnotu řádku, ve kterém nastala shoda - tedy vrátila číslo 15 (pro první řádek).

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

no osobně bych to řešil pomocným sloupcem třeba v H, kde bych udělal součet hodnot E a F - "=E&F" a pak bych do sloupce B zadal "=INDEX(E1:H5;POZVYHLEDAT(CONCATENATE(A1;B1);H:H;0);3)"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Varianta druhá je skalárním součinem=SOUČIN.SKALÁRNÍ((E:E=A1)*(F:F=B1);G:G)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Jste GÉNIUS, druhá varianta funguje dokonale!!! Díky mnohokrát za Vaši pomoc!!! :)Jen bych se ještě zeptal, kdyby se nejednalo o čísla (CENA), ale byl by tam nějaký text..?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Tomu vzorci je naprosto buřt co je uvnitř buňky, jestli text nebo číslo. Co tam najde to vrátí.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Aha...bohužel to nefunguje - vrací to nuly.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Pravda pak bude fungovat varianta jedna

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Super!! Funguje to!!Prvně mi varianta 1 chybovala, nyní běží, jak má Jste úžasný člověk, díky tisíceré!!!Buďte zdráv a s pozdravemJV

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Kolize




Určitě si přečtěte

Apple dal do MacBooku procesor Core i9 a 4TB SSD. Ani se neptejte, co za to chce...

Apple dal do MacBooku procesor Core i9 a 4TB SSD. Ani se neptejte, co za to chce...

** Apple aktualizoval notebooky MacBook Pro, dostaly nový hardware ** Těšit se můžete na nové procesory a větší paměť ** Cena nejvybavenějšího modelu překročí 200 tisíc korun

Martin Miksa | 99

Sex a rozmnožování při mezihvězdné cestě: Kolik lidí je potřeba pro let k Proximě Centauri?

Sex a rozmnožování při mezihvězdné cestě: Kolik lidí je potřeba pro let k Proximě Centauri?

** Vědci spočítali, jak velká by musela být posádka pro vícegenerační let k nejbližší hvězdné soustavě ** Proxima Centauri se nachází 4,3 světelných let od nás ** Za současných technologií bychom k ní letěli 6300 let

Petr Kubala | 53

Apple: naše mapy budou nejlepší na světě. Tajně jsme na nich pracovali několik let

Apple: naše mapy budou nejlepší na světě. Tajně jsme na nich pracovali několik let

** Apple odhalil své plány na zcela nové mapy ** Několik let pracuje na nových mapách, které by měly předběhnout konkurenci ** Objeví se s příchodem iOS 12 pro vybrané státy

Karel Javůrek | 50

Byli tam! Důkazy o přistání na Měsíci, Lunochody i čínská sonda jsou vidět z vesmíru

Byli tam! Důkazy o přistání na Měsíci, Lunochody i čínská sonda jsou vidět z vesmíru

** Sonda LRO pořídila z oběžné dráhy Měsíce zajímavé snímky ** Jsou na nich vidět artefakty všech misí programu Apolla, které přistály na povrchu Měsíce ** Jde například o části lunárních modulů, rovery a dokonce i vlajky

Petr Kubala | 60


Aktuální číslo časopisu Computer

Velký test 18 bezdrátových sluchátek

Vše o přechodu na DVB-T2

Procesory AMD opět porážejí Intel

7 NVMe M.2 SSD v přímém souboji