» Poradna » Programy

Excel - KDYŽ(A(SVYHLEDAT.. kolize

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 12/12
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Dobrý den,chtěl bych Vás moc poprosit o radu, kdy nevím, kde mám chybu ve vzorci.Pro názornost problému přikládám odkaz na obrázek, který plně vystihuje můj problém.http://uloz.to/x9wFsHZu/excelhelp-pngS díky a pozdravemJV

Odpovědi na otázku

 |   |  Microsoft Windows 8.1 IE 11.0  |  [90.176.160.---]

Chyba je zřejmá Funkce SVYHLEDAT hledá v prvním sloupci. V tebou vyznačené oblasti $F:$H se v prvním sloupci "ČR" nenachází, takže ti vzorec vrací chybu. Buď uprav oblast na $G:$H, nebo použij funkci INDEX.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

První SVYHLEDAT hledá v 1.sloupci a nachází správnou odpověď: NEPRAVDA.Problém je u druhého SVYHLEDAT, které má hledat ČR (tedy ve 2.sloupci vybrané oblasti). Bohužel zde dochází ke kolizi. Jak kdyby logická funkce A nechtěla vzít podruhé funkci SVYHLEDAT.Při Vaší radě jsem změnil oblast vyhledávání u druhého SVYHLEDAT (z $F:$H na $G:$H) a zadal hledat parametr ČR v 1.sloupci. Výsledkem bylo prázdné políčko.Cílem má být hodnota 15.Jak prosím postupovat?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Abych ještě upřesnil zadání: Mám porovnat dva parametry (OVOCE a ZEMĚ) a při shodě obou parametrů přiřadit správnou částku.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

pozn.: kdybych nechal Vaši verzi (záměna vyhledávané oblasti u druhého SVYHLEDAT), koliduje už jen podmínka KDYŽ při shodě (tedy při [ANO] = H2).Jak, prosím, nadefinovat [ANO], abych dostal správnou částku?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Nyní mám tedy tuto funkci: =KDYŽ(A(SVYHLEDAT(A2;$F:$H;1;NEPRAVDA)=NEPRAVDA;SVYHLEDAT(B2;$G:$H;1;NEPRAVDA)=NEPRAVDA);H2;"nic")a potřebuji nadefinovat podmínku [ANO] u funkce KDYŽ (doteď rovnu H2), aby vrátila hodnotu řádku, ve kterém nastala shoda - tedy vrátila číslo 15 (pro první řádek).

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [90.176.160.---]

no osobně bych to řešil pomocným sloupcem třeba v H, kde bych udělal součet hodnot E a F - "=E&F" a pak bych do sloupce B zadal "=INDEX(E1:H5;POZVYHLEDAT(CONCATENATE(A1;B1);H:H;0);3)"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [90.176.160.---]

Varianta druhá je skalárním součinem=SOUČIN.SKALÁRNÍ((E:E=A1)*(F:F=B1);G:G)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Jste GÉNIUS, druhá varianta funguje dokonale!!! Díky mnohokrát za Vaši pomoc!!! :)Jen bych se ještě zeptal, kdyby se nejednalo o čísla (CENA), ale byl by tam nějaký text..?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [90.176.160.---]

Tomu vzorci je naprosto buřt co je uvnitř buňky, jestli text nebo číslo. Co tam najde to vrátí.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Aha...bohužel to nefunguje - vrací to nuly.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [90.176.160.---]

Pravda pak bude fungovat varianta jedna

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0  |  [195.39.71.---]

Super!! Funguje to!!Prvně mi varianta 1 chybovala, nyní běží, jak má Jste úžasný člověk, díky tisíceré!!!Buďte zdráv a s pozdravemJV

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Kolize



Určitě si přečtěte



Aktuální číslo časopisu Computer

26 procesorů v důkladném testu

Zhodnotili jsme 18 bezdrátových reproduktorů

Jak fungují cash back služby?

Pohlídejte své děti na internetu