» Poradna » Programy

Excel - KDYŽ(A(SVYHLEDAT.. kolize

 |   |  Microsoft Windows 8.1 IE 11.0

Dobrý den,chtěl bych Vás moc poprosit o radu, kdy nevím, kde mám chybu ve vzorci.Pro názornost problému přikládám odkaz na obrázek, který plně vystihuje můj problém.http://uloz.to/x9wFsHZu/excelhelp-pngS díky a pozdravemJV

Odpovědi na otázku

 |   |  Microsoft Windows 8.1 IE 11.0

Chyba je zřejmá Funkce SVYHLEDAT hledá v prvním sloupci. V tebou vyznačené oblasti $F:$H se v prvním sloupci "ČR" nenachází, takže ti vzorec vrací chybu. Buď uprav oblast na $G:$H, nebo použij funkci INDEX.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

První SVYHLEDAT hledá v 1.sloupci a nachází správnou odpověď: NEPRAVDA.Problém je u druhého SVYHLEDAT, které má hledat ČR (tedy ve 2.sloupci vybrané oblasti). Bohužel zde dochází ke kolizi. Jak kdyby logická funkce A nechtěla vzít podruhé funkci SVYHLEDAT.Při Vaší radě jsem změnil oblast vyhledávání u druhého SVYHLEDAT (z $F:$H na $G:$H) a zadal hledat parametr ČR v 1.sloupci. Výsledkem bylo prázdné políčko.Cílem má být hodnota 15.Jak prosím postupovat?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Abych ještě upřesnil zadání: Mám porovnat dva parametry (OVOCE a ZEMĚ) a při shodě obou parametrů přiřadit správnou částku.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

pozn.: kdybych nechal Vaši verzi (záměna vyhledávané oblasti u druhého SVYHLEDAT), koliduje už jen podmínka KDYŽ při shodě (tedy při [ANO] = H2).Jak, prosím, nadefinovat [ANO], abych dostal správnou částku?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Nyní mám tedy tuto funkci: =KDYŽ(A(SVYHLEDAT(A2;$F:$H;1;NEPRAVDA)=NEPRAVDA;SVYHLEDAT(B2;$G:$H;1;NEPRAVDA)=NEPRAVDA);H2;"nic")a potřebuji nadefinovat podmínku [ANO] u funkce KDYŽ (doteď rovnu H2), aby vrátila hodnotu řádku, ve kterém nastala shoda - tedy vrátila číslo 15 (pro první řádek).

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

no osobně bych to řešil pomocným sloupcem třeba v H, kde bych udělal součet hodnot E a F - "=E&F" a pak bych do sloupce B zadal "=INDEX(E1:H5;POZVYHLEDAT(CONCATENATE(A1;B1);H:H;0);3)"

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Varianta druhá je skalárním součinem=SOUČIN.SKALÁRNÍ((E:E=A1)*(F:F=B1);G:G)

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Jste GÉNIUS, druhá varianta funguje dokonale!!! Díky mnohokrát za Vaši pomoc!!! :)Jen bych se ještě zeptal, kdyby se nejednalo o čísla (CENA), ale byl by tam nějaký text..?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Tomu vzorci je naprosto buřt co je uvnitř buňky, jestli text nebo číslo. Co tam najde to vrátí.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Aha...bohužel to nefunguje - vrací to nuly.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Pravda pak bude fungovat varianta jedna

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 8.1 IE 11.0

Super!! Funguje to!!Prvně mi varianta 1 chybovala, nyní běží, jak má Jste úžasný člověk, díky tisíceré!!!Buďte zdráv a s pozdravemJV

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Kolize




Určitě si přečtěte

Tohle tak jednou zažít: Nová vzducholoď Airlander 10 s prosklenou podlahou

Tohle tak jednou zažít: Nová vzducholoď Airlander 10 s prosklenou podlahou

** Airlander 10 nabídne plavby vzduchem v interiéru s prosklenou podlahou ** Luxusní vzducholoď byla původně vyvíjena pro vojenské účely ** Počítá se s třídenními „kochacími“ výlety za poznáním

Karel Kilián | 7

Modelářský zázrak: Maketa raketoplánu Columbia, která létá jako skutečná raketa

Modelářský zázrak: Maketa raketoplánu Columbia, která létá jako skutečná raketa

** Model raketoplánu Columbia od českého konstruktéra umí i létat ** Obdivuhodný model si vzal 1600 hodin práce ** Podívejte se na fotografie ze stavby a prvního letu

Karel Jeřábek | 20

Osudová havárie Concordu: Před 18 lety přišel konec nadzvukových dopravních letadel

Osudová havárie Concordu: Před 18 lety přišel konec nadzvukových dopravních letadel

** Concorde byl nejrychlejším dopravním letadlem ** Atlantik dokázal přeletět za cca 3 až 3,5 hodiny ** Před osmnácti lety tragická havárie provoz těchto letadel prakticky ukončila

David Polesný, Jiří Černý | 37

Jak horko bude ve vašem městě, až vám bude 80 let? Podívejte se, jak se projeví klimatické změny!

Jak horko bude ve vašem městě, až vám bude 80 let? Podívejte se, jak se projeví klimatické změny!

** Srpen byl třetí nejteplejší za posledních více než sto let ** Bude to ale daleko horší, jak ukazuje aplikace NYT ** V Praze vzroste počet horkých dní na čtyřnásobek

Karel Kilián | 21


Aktuální číslo časopisu Computer

Jak vytvořit a spravovat vlastní web

Velký test herních klávesnic a DVB-T2 tunerů

Vše o formátu RAW

Vybíráme nejlepší základní desku