» Poradna » Programy

Excel - automatické vložení statického aktuálního data

Odpovědět  |  Zobrazit bez stromu  |  Upozornit redakci  |  nových odpovědí: 5/5
 |   |  Microsoft Windows 7 Firefox 8.0  |  [89.111.73.---]

Nevěděl by jste někdo jak v Execelu udělat, aby pokud buňka A1 není prázdná (nebo ji někdo vyplní), tak aby se do buňky A2 sám vložil aktuální datum? Ale tak, aby se ten datum už neměnil - např. když se sešit uloží a otevře druhý den, aby se tam neobjevil aktuální datum z toho druhého dne. Datum by tam měl zůstat i v případě, že nědko buňku A1 vymaže - toto bych mohl i oželet, ale bylo by dobré, kdyby to šlo.Snad jsem to posal pochopitelně.

Odpovědi na otázku

 |   |  Microsoft Windows 7 Chrome 26.0.1410.64  |  [90.177.110.---]

Zkus to takhle:1. Povolíš iterativní přepočet (Soubor - Možnosti - Vzorce)2. A2: =KDYŽ(A1<> "";KDYŽ(A2="";NYNÍ();A2);"")3. Buňce A2 nastavíš formát datumVšechno funguje kromě požadavku v poslední větě - po výmazu A1 se vymaže i A2.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 8.0  |  [89.111.73.---]

Bohužel to nefunguje. Když tabulku uložím a zavřu, pak změním systémové datum a znovu tabulku otevřu, tak se datum změní na to co je nastavené v systému.

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 20.0  |  [178.255.168.---]

Volil bych použití jednoduchého makraALT+F11, otevře se editor VBA a do příslušného modulu listu se vloží:Private Sub Worksheet_Change(ByVal Target As Range) If Range("A1").Value <> "" Then Range("A2").Value = Date End IfEnd Sub

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Firefox 8.0  |  [89.111.77.---]

Dík, ale potřebuji, aby to fungovalo i pro další řádky. Minimálně takových 10.000 řádků. Jde to nějak?

Souhlasím  |  Nesouhlasím  |  Odpovědět
 |   |  Microsoft Windows 7 Chrome 26.0.1410.64  |  [90.180.5.---]

Tak to jsi musel nějak upravit, protože mně to po změně data a znovuotevření drží původní datum.

Souhlasím  |  Nesouhlasím  |  Odpovědět

Související témata: Buňka



Určitě si přečtěte



Aktuální číslo časopisu Computer

26 procesorů v důkladném testu

Zhodnotili jsme 18 bezdrátových reproduktorů

Jak fungují cash back služby?

Pohlídejte své děti na internetu