Software | Programování | Bulvár a vtípky

12 nejšílenějších programovacích jazyků, ze kterých vám praskne hlava

  • Myslíte si, že umíte programovat?
  • Ale prosím vás, zkuste jazyk Wenyan nebo Malbolge
  • Z ezoterických jazyků zešílíte, nebo vás zaměstnají v Googlu

K nejpopulárnějším i nejpoužívanějším programovacím jazykům už dlouhé roky patří Javascript, Python, Java, PHP, C# a samozřejmě také klasika C/C++. Slyšel o nich naprosto každý, nehledě na to, zdali jej živí vývoj softwaru, anebo cokoliv jiného.

Vedle těchto ikon počítačového světa však máme k dispozici i hromadu bizarních jazyků, ve kterých asi rozumný člověk nic programovat nebude – natož aby v nich implementoval třeba tuzemské systémy pro EET, dálniční známky a správu sociálního zabezpečení.

Obecně se jim říká ezoterické programovací jazyky a vznikly z rozličných důvodů počínaje prostým smyslem pro humor a konče hledání teoretických i praktických hranic, jakým způsobem vyjádřit libovolný počítačový algoritmus.

Pojďme se na některé z nich podívat.

文言

Jeden z nejmladších ezoterických programovacích jazyků se na scéně objevil teprve nedávno. Jmenuje se Wenyan – stejně jako předloha, jedná se totiž o klasickou literární čínštinu, jejíž kořeny sahají hluboko do starověku.

I kdyby se však jednalo o tu moderní, asi se nic nezmění – tedy pokud jste se posledních pár let nevěnovali sinologii.

Ukázkový program, který nakreslí srdíčko:

吾嘗觀「「算經」」之書。方悟「絕對」「平方根」之義。

吾有一術名之曰「畫心」。
欲行是術。必先得一言。曰「心語」。
乃行是術曰。
	夫「心語」之長。名之曰「長度」。
	吾有一言。曰「「一」」。名之曰「填充符」。
	吾有一言。曰「「\n」」。名之曰「换行符」。
	除十三以十。名之曰「乙」。
	除負十一以十。名之曰「乙止」。
	除四十以一千。名之曰「甲步長」。
	除六以一百。名之曰「乙步長」。
	吾有一數。曰一。名之曰「輸出位置」。
	吾有一言。曰「「」」。名之曰「果」。
	恆為是。若「乙」小於「乙止」者乃止也。
		除負十一以十。名之曰「甲」。
		除十一以十。名之曰「甲止」。
		吾有一言。曰「「」」。名之曰「本行」。
		恆為是。若「甲」大於「甲止」者乃止也。
			施「絕對」於「甲」。名之曰「甲絕對」。
			施「平方根」於「甲絕對」。名之曰「減數」。
			乘五於「乙」。除其以四。名之曰「被減數」。
			減「被減數」以「減數」。名之曰「差」。
			乘「差」以「差」。名之曰「加數」。
			乘「甲」以「甲」。加其以「加數」。減其以一。名之曰「函數值」。
			若「函數值」不大於零者。
				夫「心語」之「輸出位置」。名之曰「字」。
				加「本行」以「字」。昔之「本行」者今其是矣。
				除「輸出位置」以「長度」。所餘幾何。加其以一。昔之「輸出位置」者今其是矣。
			若非。
				加「本行」以「填充符」。昔之「本行」者今其是矣。
			终也。
			加「甲」以「甲步長」。昔之「甲」者今其是矣。
		云云。
		減「乙」以「乙步長」。昔之「乙」者今其是矣。
		加「本行」以「换行符」。昔之「本行」者今其是矣。
		加「果」以「本行」。昔之「果」者今其是矣。
	云云。
	吾有一言。曰「果」。書之。
是謂「畫心」之術也。

施「畫心」於「「琉璃梳子撫青絲。畫心牽腸癡不癡。」」。

Pro člověka ze západu to bude jistě prakticky nečitelná hatmatilka, která by byla pro Číňany stejně nepochopitelná jako hypotetický ezoterický jazyk, který by naopak použil staroslověnštinu a její písmo hlaholici.

Klepněte pro větší obrázek
Webový editor (nahoře vlevo), překladač do Javascriptu (nahoře vpravo) a interpret (dole)

Jazyk má přitom svoji bohatou slovní zásobu, zatím poměrně živou komunitu na GitHubu a hromadu překladačů do Javascriptu, Pythonu a dalších. Nechybí ani webový editor a překladač, takže si můžete vyzkoušet hromadu funkčních ukázek.

Diskuze (28) Další článek: E-shop na dálniční známky by měl stát přibližně půlku původního rozpočtu, říká současný ministr

Témata článku: Software, Google, Programování, Wikipedia, Kód, C++, Linkedin, GitHub, Bulvár a vtípky, Python, Slovensko, Java, Javascript, Ostrava, Beautiful, Hello World!, Kompilátor, Podobný jazyk, Bowl, Jazyk, Horse, Chicken, Kompilát, Výkřik, Chocolate


Určitě si přečtěte

WindowsFX: Nainstalujte to mamce a taťkovi. Ani nepoznají, že to je Linux

WindowsFX: Nainstalujte to mamce a taťkovi. Ani nepoznají, že to je Linux

** Po dvou měsících tu máme další linuxovou kopii ** Tentokrát jde o imitaci Desítek ** Sestavili ji brazilští geekové nad Ubuntu

Jakub Čížek | 135

Je to dobré, cetky z AliExpressu budou nejspíše relativně levné i v roce 2021

Je to dobré, cetky z AliExpressu budou nejspíše relativně levné i v roce 2021

** V roce 2021 začneme platit DPH i u laciného zboží z asijských e-shopů ** Daň ale budeme většinou platit už na e-shopech ** Nemusíte se bát zdlouhavého a drahého celního řízení

Jakub Čížek | 75

12 netradičních map České republiky, které jste ještě nikdy neviděli

12 netradičních map České republiky, které jste ještě nikdy neviděli

** Tušíte, kolik je u nás hřbitovů a jak jsou velké? ** Dokážete si představit mapu českých řek a potoků? ** Udělali jsme to všechno za vás nad daty ČÚZK

Jakub Čížek | 10

Vyrobíme si falešný Mac mini za tisícovku. Stačí Raspberry Pi a 3D tiskárna

Vyrobíme si falešný Mac mini za tisícovku. Stačí Raspberry Pi a 3D tiskárna

** Vyzkoušíme Raspberry Pi 4 s iRaspbianem ** Operační systém vypadá skoro jako macOS ** Vše strčíme do vlastní stylové krabice

Jakub Čížek | 31

Na měsíc jsem opustil Google a potupně se zase vrátil zpět (komentář)

Na měsíc jsem opustil Google a potupně se zase vrátil zpět (komentář)

** Zkusil jsem se zbavit závislosti na vyhledávači od Googlu ** Jako alternativy posloužily Bing, Seznam a DuckDuckGo ** Mají své silné stránky, ale i nepřekonatelná negativa

Lukáš Václavík | 58


Aktuální číslo časopisu Computer

Megatest: nejlepší notebooky do 20 000 Kč

Test 8 levných IP kamer

Jak vybrat bezdrátová sluchátka

Testujeme Android 11