Software | Programování | Bulvár a vtípky

12 nejšílenějších programovacích jazyků, ze kterých vám praskne hlava

  • Myslíte si, že umíte programovat?
  • Ale prosím vás, zkuste jazyk Wenyan nebo Malbolge
  • Z ezoterických jazyků zešílíte, nebo vás zaměstnají v Googlu

K nejpopulárnějším i nejpoužívanějším programovacím jazykům už dlouhé roky patří Javascript, Python, Java, PHP, C# a samozřejmě také klasika C/C++. Slyšel o nich naprosto každý, nehledě na to, zdali jej živí vývoj softwaru, anebo cokoliv jiného.

Vedle těchto ikon počítačového světa však máme k dispozici i hromadu bizarních jazyků, ve kterých asi rozumný člověk nic programovat nebude – natož aby v nich implementoval třeba tuzemské systémy pro EET, dálniční známky a správu sociálního zabezpečení.

Obecně se jim říká ezoterické programovací jazyky a vznikly z rozličných důvodů počínaje prostým smyslem pro humor a konče hledání teoretických i praktických hranic, jakým způsobem vyjádřit libovolný počítačový algoritmus.

Pojďme se na některé z nich podívat.

文言

Jeden z nejmladších ezoterických programovacích jazyků se na scéně objevil teprve nedávno. Jmenuje se Wenyan – stejně jako předloha, jedná se totiž o klasickou literární čínštinu, jejíž kořeny sahají hluboko do starověku.

I kdyby se však jednalo o tu moderní, asi se nic nezmění – tedy pokud jste se posledních pár let nevěnovali sinologii.

Ukázkový program, který nakreslí srdíčko:

吾嘗觀「「算經」」之書。方悟「絕對」「平方根」之義。

吾有一術名之曰「畫心」。
欲行是術。必先得一言。曰「心語」。
乃行是術曰。
	夫「心語」之長。名之曰「長度」。
	吾有一言。曰「「一」」。名之曰「填充符」。
	吾有一言。曰「「\n」」。名之曰「换行符」。
	除十三以十。名之曰「乙」。
	除負十一以十。名之曰「乙止」。
	除四十以一千。名之曰「甲步長」。
	除六以一百。名之曰「乙步長」。
	吾有一數。曰一。名之曰「輸出位置」。
	吾有一言。曰「「」」。名之曰「果」。
	恆為是。若「乙」小於「乙止」者乃止也。
		除負十一以十。名之曰「甲」。
		除十一以十。名之曰「甲止」。
		吾有一言。曰「「」」。名之曰「本行」。
		恆為是。若「甲」大於「甲止」者乃止也。
			施「絕對」於「甲」。名之曰「甲絕對」。
			施「平方根」於「甲絕對」。名之曰「減數」。
			乘五於「乙」。除其以四。名之曰「被減數」。
			減「被減數」以「減數」。名之曰「差」。
			乘「差」以「差」。名之曰「加數」。
			乘「甲」以「甲」。加其以「加數」。減其以一。名之曰「函數值」。
			若「函數值」不大於零者。
				夫「心語」之「輸出位置」。名之曰「字」。
				加「本行」以「字」。昔之「本行」者今其是矣。
				除「輸出位置」以「長度」。所餘幾何。加其以一。昔之「輸出位置」者今其是矣。
			若非。
				加「本行」以「填充符」。昔之「本行」者今其是矣。
			终也。
			加「甲」以「甲步長」。昔之「甲」者今其是矣。
		云云。
		減「乙」以「乙步長」。昔之「乙」者今其是矣。
		加「本行」以「换行符」。昔之「本行」者今其是矣。
		加「果」以「本行」。昔之「果」者今其是矣。
	云云。
	吾有一言。曰「果」。書之。
是謂「畫心」之術也。

施「畫心」於「「琉璃梳子撫青絲。畫心牽腸癡不癡。」」。

Pro člověka ze západu to bude jistě prakticky nečitelná hatmatilka, která by byla pro Číňany stejně nepochopitelná jako hypotetický ezoterický jazyk, který by naopak použil staroslověnštinu a její písmo hlaholici.

Klepněte pro větší obrázek
Webový editor (nahoře vlevo), překladač do Javascriptu (nahoře vpravo) a interpret (dole)

Jazyk má přitom svoji bohatou slovní zásobu, zatím poměrně živou komunitu na GitHubu a hromadu překladačů do Javascriptu, Pythonu a dalších. Nechybí ani webový editor a překladač, takže si můžete vyzkoušet hromadu funkčních ukázek.

Diskuze (28) Další článek: E-shop na dálniční známky by měl stát přibližně půlku původního rozpočtu, říká současný ministr

Témata článku: Software, Google, Programování, Linkedin, Python, Wikipedia, Bulvár a vtípky, GitHub, Slovensko, Ostrava, Javascript, Java, Kód, C++, Proměnná, Dark, Změť, Water, Alfanumerický znak, Scala, LOL, Kompilát, OMG, Výkřik, Beautiful, Software na Heureka.cz



Sex manželských párů? Jen výjimečně. Ložnice ovládnou roboti s umělou inteligencí

Sex manželských párů? Jen výjimečně. Ložnice ovládnou roboti s umělou inteligencí

** Sex manželských párů jen při zvláštních příležitostech. ** Ložnice ovládnou sexuální roboti s umělou inteligencí. ** I to je jeden ze závěrů Mezinárodní robotické konference.

Filip KůželJiří Liebreich
RobotiSexUmělá inteligence
25 nejlepších filmových parodií, které můžete vidět. Víme, kde je najdete online

25 nejlepších filmových parodií, které můžete vidět. Víme, kde je najdete online

Filmové parodie jsou divácky velmi vděčné a mezi filmaři oblíbené. Tvůrci v nich mohou totiž zcela beztrestně vykrádat cizí díla a v jejich nápodobě popustit uzdu své fantazii. Vybrali jsme nejlepší zahraniční i české parodie.

Jaromír PukMarek Čech
Filmy, které musíte vidět
Samohybná houfnice CAESAR zasáhla projektilem Excalibur cíl vzdálený 46 km. To je dělostřelecký rekord

Samohybná houfnice CAESAR zasáhla projektilem Excalibur cíl vzdálený 46 km. To je dělostřelecký rekord

** Raytheon a Nexter použili houfnici CAESAR k testu naváděné dělostřelecké munice s prodlouženým dostřelem Excalibur ** Při této zkoušce zasáhla dotyčná munice dva cíle ve vzdálenosti přesahující 46 kilometrů ** To je nový rekord pro palbu dělostřeleckého systému

Stanislav Mihulka
RekordyZbraněArmáda
Jak zrcadlit obrazovku mobilu a počítače do televize

Jak zrcadlit obrazovku mobilu a počítače do televize

Ať už se chcete pochlubit fotkami z dovolené na velké obrazovce, nebo si přehrát video uložené na disku počítače, neobejdete se bez zrcadlení obrazovky. Ve výchozím stavu jej podporuje Windows i Android.

Stanislav Janů
NávodyTelevizeWindows
Jak rozmazat dům, aby vás sousedi nemohli šmírovat. Jde to v Mapách Google i na Mapy.cz

Jak rozmazat dům, aby vás sousedi nemohli šmírovat. Jde to v Mapách Google i na Mapy.cz

** Nelibí se vám, když cizí lidé okukují váš dům? ** Všechny mapové aplikace nabízejí možnost rozmazání snímku ** Máme návod pro Apple Maps, Bing Maps, Mapy Google a Mapy.cz

Karel Kilián
SoukromíNávodyMapy