Software | Programování | Bulvár a vtípky

12 nejšílenějších programovacích jazyků, ze kterých vám praskne hlava

  • Myslíte si, že umíte programovat?
  • Ale prosím vás, zkuste jazyk Wenyan nebo Malbolge
  • Z ezoterických jazyků zešílíte, nebo vás zaměstnají v Googlu

K nejpopulárnějším i nejpoužívanějším programovacím jazykům už dlouhé roky patří Javascript, Python, Java, PHP, C# a samozřejmě také klasika C/C++. Slyšel o nich naprosto každý, nehledě na to, zdali jej živí vývoj softwaru, anebo cokoliv jiného.

Vedle těchto ikon počítačového světa však máme k dispozici i hromadu bizarních jazyků, ve kterých asi rozumný člověk nic programovat nebude – natož aby v nich implementoval třeba tuzemské systémy pro EET, dálniční známky a správu sociálního zabezpečení.

Obecně se jim říká ezoterické programovací jazyky a vznikly z rozličných důvodů počínaje prostým smyslem pro humor a konče hledání teoretických i praktických hranic, jakým způsobem vyjádřit libovolný počítačový algoritmus.

Pojďme se na některé z nich podívat.

文言

Jeden z nejmladších ezoterických programovacích jazyků se na scéně objevil teprve nedávno. Jmenuje se Wenyan – stejně jako předloha, jedná se totiž o klasickou literární čínštinu, jejíž kořeny sahají hluboko do starověku.

I kdyby se však jednalo o tu moderní, asi se nic nezmění – tedy pokud jste se posledních pár let nevěnovali sinologii.

Ukázkový program, který nakreslí srdíčko:

吾嘗觀「「算經」」之書。方悟「絕對」「平方根」之義。

吾有一術名之曰「畫心」。
欲行是術。必先得一言。曰「心語」。
乃行是術曰。
	夫「心語」之長。名之曰「長度」。
	吾有一言。曰「「一」」。名之曰「填充符」。
	吾有一言。曰「「\n」」。名之曰「换行符」。
	除十三以十。名之曰「乙」。
	除負十一以十。名之曰「乙止」。
	除四十以一千。名之曰「甲步長」。
	除六以一百。名之曰「乙步長」。
	吾有一數。曰一。名之曰「輸出位置」。
	吾有一言。曰「「」」。名之曰「果」。
	恆為是。若「乙」小於「乙止」者乃止也。
		除負十一以十。名之曰「甲」。
		除十一以十。名之曰「甲止」。
		吾有一言。曰「「」」。名之曰「本行」。
		恆為是。若「甲」大於「甲止」者乃止也。
			施「絕對」於「甲」。名之曰「甲絕對」。
			施「平方根」於「甲絕對」。名之曰「減數」。
			乘五於「乙」。除其以四。名之曰「被減數」。
			減「被減數」以「減數」。名之曰「差」。
			乘「差」以「差」。名之曰「加數」。
			乘「甲」以「甲」。加其以「加數」。減其以一。名之曰「函數值」。
			若「函數值」不大於零者。
				夫「心語」之「輸出位置」。名之曰「字」。
				加「本行」以「字」。昔之「本行」者今其是矣。
				除「輸出位置」以「長度」。所餘幾何。加其以一。昔之「輸出位置」者今其是矣。
			若非。
				加「本行」以「填充符」。昔之「本行」者今其是矣。
			终也。
			加「甲」以「甲步長」。昔之「甲」者今其是矣。
		云云。
		減「乙」以「乙步長」。昔之「乙」者今其是矣。
		加「本行」以「换行符」。昔之「本行」者今其是矣。
		加「果」以「本行」。昔之「果」者今其是矣。
	云云。
	吾有一言。曰「果」。書之。
是謂「畫心」之術也。

施「畫心」於「「琉璃梳子撫青絲。畫心牽腸癡不癡。」」。

Pro člověka ze západu to bude jistě prakticky nečitelná hatmatilka, která by byla pro Číňany stejně nepochopitelná jako hypotetický ezoterický jazyk, který by naopak použil staroslověnštinu a její písmo hlaholici.

Klepněte pro větší obrázek
Webový editor (nahoře vlevo), překladač do Javascriptu (nahoře vpravo) a interpret (dole)

Jazyk má přitom svoji bohatou slovní zásobu, zatím poměrně živou komunitu na GitHubu a hromadu překladačů do Javascriptu, Pythonu a dalších. Nechybí ani webový editor a překladač, takže si můžete vyzkoušet hromadu funkčních ukázek.

Diskuze (25) Další článek: E-shop na dálniční známky by měl stát přibližně půlku původního rozpočtu, říká současný ministr

Témata článku: Google, Software, Wikipedia, Programování, Linkedin, Bulvár a vtípky, GitHub, Kód, Java, C++, Slovensko, Ostrava, Javascript, Python, Bowl, Cream, Podobný experiment, Chicken, Shakespeare, Nad ránem, Sacred, Alfanumerický znak, Mezera, Arnold, Slang


Určitě si přečtěte

Nový Edge je opravdu Chrome! Prohnali jsme prohlížeče benchmarky i vlastním unikátním testem

Nový Edge je opravdu Chrome! Prohnali jsme prohlížeče benchmarky i vlastním unikátním testem

** Nový Edge je postavený na Chromiu ** Prohnali jsme ho benchmarky a srovnali s ostatními ** Potvrdily nám, že je prakticky stejný jako Chrome a Opera

Jakub Čížek | 65

Nejlevnější router s Wi-Fi 6 v testu: vážně ještě chcete kupovat routery jen pro 802.11ac?

Nejlevnější router s Wi-Fi 6 v testu: vážně ještě chcete kupovat routery jen pro 802.11ac?

** Otestovali jsme TP-Link Archer AX10, nejdostupnější router s Wi-Fi 6 ** Šetřilo se, ale zatím ty ústupky tolik nebolí ** Pro domácí síťování pohodlná volba, do firmy ale chcete něco lepšího

Tomáš Holčík | 44

Český Turris MOX: Nejbláznivější síťový počítač nejen pro fanoušky Lega

Český Turris MOX: Nejbláznivější síťový počítač nejen pro fanoušky Lega

** CZ.NIC začal prodávat svůj Turris MOX ** Z několika základních jednotek postavíte skoro cokoliv ** Kompletní Wi-Fi router, rozsáhlý switch i univerzální linuxový server

Jakub Čížek | 32

Měření rychlosti internetu: Populární Speedtest.net neřekne o skutečné rychlosti internetu téměř nic

Měření rychlosti internetu: Populární Speedtest.net neřekne o skutečné rychlosti internetu téměř nic

** Speedtest stále častěji měří jen rychlost na poslední míli ** Ta však ale neodpovídá reálnému surfování ** Jak se tedy pokusit změřit tu skutečnou?

Jakub Čížek | 85

Vyzkoušeli jsme TP-Link Deco P9: zajistí doma Wi-Fi díky drátům ve zdi

Vyzkoušeli jsme TP-Link Deco P9: zajistí doma Wi-Fi díky drátům ve zdi

** Nová generace Mesh Wi-Fi s propojením přes elektrické rozvody ** Lepší parametry a nižší cena než u předchůdce ** Aplikace zatím podporuje jen základní nastavení bez rozšířených funkcí

Tomáš Holčík | 25

Srovnali jsme česká města s IBM, Googlem nebo třeba Samsungem. Podívejte se, v jaké firmě „žijete“

Srovnali jsme česká města s IBM, Googlem nebo třeba Samsungem. Podívejte se, v jaké firmě „žijete“

** Nadnárodní korporace zaměstnávají stovky tisíc lidí ** Mají tedy velikost metropolí ** Srovnali jsme je s českými krajskými městy

Jakub Čížek | 15



Aktuální číslo časopisu Computer

Velký test autokamer

Test ATX skříní

Jak surfovat pohodlně

Sportovní aplikace

Jak funguje procesor