Procesory Intel Skylake a Kaby Lake mají závažnou chybu v HyperThreadingu, způsobí i pád celého systému

Procesory Intel Skylake a Kaby Lake mají závažnou chybu v HyperThreadingu, způsobí i pád celého systému

Vyšší modely procesorů Intel s architekturou Skylake a Kaby Lake jsou obvykle vybavené HyperThreadingem, který umožňuje virtuální běh dvojnásobného počtu vláken na daných jádrech. Jak ale zjistili vývojáři Debianu, tato šestá a sedmá generace procesorů má v HyperThreadingu závažnou chybu.

Chyba se projevuje tak, že za určitých okolností při zpracování instrukcí způsobí chyby, zamrznutí aplikací či zaseknutí a pád celého systému. Nezáleží přitom na operačním systému ani druhu procesoru - může jít o Core i Xeon či jiné, které mají HyperThreading.

Intel o této chybě už věděl dříve a tak trochu potají omezeně vydal opravu v podobě aktualizovaného mikrokódu (firmware procesoru) skrze speciální ovladač pro operační systémy na bázi Linuxu. Dle informací webu Arstechnica zatím není k dispozici oprava pro operační systémy Windows, takže pokud provozujete na takovém systému něco kritického, měli byste do té doby raději ručně vypnout HyperThreading v biosu.

Témata článku: Bezpečnost, Čipy, Intel, Procesory, Kaby Lake, Crash, Chyba, Sedmá generace, Skylake, Ars Technica, Core X, Hyperthreading, Sky, Proces, Způsob, Hyper-threading

13 komentářů

Nejnovější komentáře

  • zivyk 28. 6. 2017 10:28:40
    CPU microcode sa da aktualizovat aj vo windows. Pre zistenie aktualnej...
  • Pety 27. 6. 2017 20:01:46
    Chyba byla objevena v linuxu, zřejmě proto, že microsoftí překladač...
  • JelenZVysočiny 27. 6. 2017 15:44:38
    Třeba pomůže tento návod na https://www.sasinos.cz/intel-microcode-fix/
Určitě si přečtěte


Aktuální číslo časopisu Computer

Velký test NVMe a SATA SSD

Máte slabý signál
Wi-Fi? Poradíme!

Jak umělá inteligence opravuje fotky

Kupujete dron? Ty levné se nevyplatí