Nový Apache 2.0.45 opravuje vážnou neznámou chybu

Apache Software Foundation a Apache HTTP Server Project zveřejnili novou verzi 2.0.45 serveru Apache. Tato verze je především opravnou verzí, seznam chyb je k dispozici na serveru Apache.org. Co je ale nejzajímavější je to, co tam vůbec není uvedeno, verze 2.0.45 totiž má opravovat také bezpečnostní chybu umožňující útok typu Denial of Service na všechny servery Apache 2.0.x. Tato oprava je ale zveřejněna bez upřesnění toho, co ve skutečnosti opravuje.

Původně měly být informace odtajněny včera, zatím se ale tak nestalo. Chybu našli lidé z iDefense.com, kde popis chyby ještě není k dispozici. Chyba bude tedy zřejmě poměrně vážná, není totiž rozhodně obvyklé (natož u Open Source) zveřejňovat opravu bez toho, aby se současně řeklo, co vlastně opravuje.

Diskuze (16) | Testy prvních SerialATA pevných disků

Témata článku: Software, Open source, Chyba, Nový, Nová chyba, Apache

Určitě si přečtěte


Aktuální číslo časopisu Computer

Zachraňte nefunkční Windows

Jak nakupovat a prodávat kryptoměny

Otestovali jsme konvertibilní notebooky

Velký test 14 herních myší