Blogovací systém WordPress dává sbohem PHP 4 a MySQL 4

Blogovací systém WordPress dává sbohem PHP 4 a MySQL 4

Oblíbený blogovací systém WordPress 3.1, který se objeví koncem letošního roku, bude poslední verzí, která podporuje PHP 4. V polovině roku 2011 se má objevit WordPress 3.2, který již bude vyžadovat nejméně PHP 5.2. Stejně se k situaci staví konkurenční systémy Drupal a Joomla, jejich požadavky půjdou s novými verzemi ve stejném duchu.

Vývojáři se rozhodli pro PHP 5.2 především proto, že to je majoritou nejpoužívanější verze, navíc přináší značná vylepšení oproti předchozím verzím. Pouze asi 11 % instalací WordPressu běží na nižší verzi než PHP 5.2.

Podobně tomu bude v případě databáze MySQL. Podpora MySQL 4 bude ukončena k verzi WordPress 3.1.  WordPress 3.2 bude minimálně požadovat MySQL 5.0.15.

Jak je známo, vývoj větve MySQL 5.0 byl ukončen v prosinci loňského roku. Momentálně vývojáři pouze opravují bezpečnostní chyby a kritické chyby. Pokud tedy budete přecházet, rozumnější volbou je samozřejmě aktuální MySQL 5.1. Jinak tomu není ani v případě PHP, kde byste měli spíše sáhnout po novém PHP 5.3, o kterém jsme včera psali na Živě.

Uživatelům s nepodporovanými verzemi nebude nabídnuta možnost upgradu na novou verzi WordPressu.

Témata článku: Software, Programování, Open source, PHP, Wordpress

25 komentářů

Nejnovější komentáře

  • pavelevap 26. 7. 2010 13:44:36
    WordPress je opensource a nevlastní ho nikdo :-) Ta komerční firma se na...
  • 26. 7. 2010 12:44:56
    Aha, to jsem nevěděl. Samozřejmě systém a hosting rozlišuji, jenom jsem...
  • pavelevap 26. 7. 2010 11:23:00
    Rozlišujte prosím WordPress.com, kde si mohou lidé zakládat zdarma blogy...
Určitě si přečtěte

To tu ještě nebylo. Specialisté ukázali, že zavirované mohou být i titulky SRT

To tu ještě nebylo. Specialisté ukázali, že zavirované mohou být i titulky SRT

** Stáhnete si film a titulky třeba z OpenSubtitles.org ** A osud vás za ten warez záhy potrestá ** Specialisté totiž ukázali, že i v titulcích může být schovaný virus

24.  5.  2017 | Jakub Čížek | 57

WannaCry se neměl vůbec rozšířit. Stačilo, abychom používali Windows Update

WannaCry se neměl vůbec rozšířit. Stačilo, abychom používali Windows Update

** WannaCry se masivně rozšířil kvůli zranitelnosti ve Windows ** Ta mu umožnila, aby se pokusil sám napadnout další počítače ** Jenže ta chyba už je dva měsíce opravená!

22.  5.  2017 | Jakub Čížek | 96


Aktuální číslo časopisu Computer

Bojujeme proti Fake News

Dva velké testy: fotoaparáty a NASy

Co musíte vědět o změně evropského roamingu

Radíme s výběrem základní desky